summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mono-debugger')
-rw-r--r--dev-util/mono-debugger/ChangeLog8
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-kernel-2.6.19-fix-i386-asm.patch66
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.0.9999.ebuild22
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.0.ebuild27
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.4.2-r1.ebuild46
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.4.2.ebuild27
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.4.9999.ebuild22
7 files changed, 7 insertions, 211 deletions
diff --git a/dev-util/mono-debugger/ChangeLog b/dev-util/mono-debugger/ChangeLog
index 395082c15a4b..396b4287ca12 100644
--- a/dev-util/mono-debugger/ChangeLog
+++ b/dev-util/mono-debugger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mono-debugger
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.40 2010/09/23 22:15:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.41 2010/10/07 20:18:43 pacho Exp $
+
+ 07 Oct 2010; Pacho Ramos <pacho@gentoo.org> -mono-debugger-2.0.ebuild,
+ -mono-debugger-2.0.9999.ebuild, -mono-debugger-2.4.2.ebuild,
+ -mono-debugger-2.4.2-r1.ebuild, -mono-debugger-2.4.9999.ebuild,
+ -files/mono-debugger-kernel-2.6.19-fix-i386-asm.patch:
+ Remove old.
23 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
mono-debugger-2.6.3.ebuild:
diff --git a/dev-util/mono-debugger/files/mono-debugger-kernel-2.6.19-fix-i386-asm.patch b/dev-util/mono-debugger/files/mono-debugger-kernel-2.6.19-fix-i386-asm.patch
deleted file mode 100644
index 744dec04a86d..000000000000
--- a/dev-util/mono-debugger/files/mono-debugger-kernel-2.6.19-fix-i386-asm.patch
+++ /dev/null
@@ -1,66 +0,0 @@
---- backend/server/i386-arch.h.orig 2007-06-26 09:14:11.000000000 -0400
-+++ backend/server/i386-arch.h 2007-06-26 23:07:08.000000000 -0400
-@@ -2,12 +2,63 @@
- #define __MONO_DEBUGGER_I386_ARCH_H__
-
- #include <glib.h>
-+#include <linux/version.h>
-
- G_BEGIN_DECLS
-
- #if defined(__i386__)
-
-+/*
-+ * added because gentoo linux headers
-+ * no longer include asm-i386/user.h
-+ */
-+
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
-+
-+ struct user_i387_struct {
-+ long cwd;
-+ long swd;
-+ long twd;
-+ long fip;
-+ long fcs;
-+ long foo;
-+ long fos;
-+ long st_space[20];
-+ };
-+
-+ struct user_regs_struct {
-+ long ebx, ecx, edx, esi, edi, ebp, eax;
-+ unsigned short ds, __ds, es, __es;
-+ unsigned short fs, __fs, gs, __gs;
-+ long orig_eax, eip;
-+ unsigned short cs, __cs;
-+ long eflags, esp;
-+ unsigned short ss, __ss;
-+ };
-+
-+ struct user{
-+ struct user_regs_struct regs;
-+ int u_fpvalid;
-+ struct user_i387_struct i387;
-+ unsigned long int u_tsize;
-+ unsigned long int u_dsize;
-+ unsigned long int u_ssize;
-+ unsigned long start_code;
-+ unsigned long start_stack;
-+ long int signal;
-+ int reserved;
-+ struct user_pt_regs * u_ar0;
-+ struct user_i387_struct* u_fpstate;
-+ unsigned long magic;
-+ char u_comm[32];
-+ int u_debugreg[8];
-+ };
-+
-+#else
- #include <asm/user.h>
-+#endif
-+
-+/* end added structs */
-
- #define INFERIOR_REGS_TYPE struct user_regs_struct
- #define INFERIOR_FPREGS_TYPE struct user_i387_struct
diff --git a/dev-util/mono-debugger/mono-debugger-2.0.9999.ebuild b/dev-util/mono-debugger/mono-debugger-2.0.9999.ebuild
deleted file mode 100644
index d9b88845e74a..000000000000
--- a/dev-util/mono-debugger/mono-debugger-2.0.9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.0.9999.ebuild,v 1.3 2009/06/09 21:19:11 loki_val Exp $
-
-EAPI=2
-
-inherit go-mono mono
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="sys-libs/readline
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-RESTRICT="test"
diff --git a/dev-util/mono-debugger/mono-debugger-2.0.ebuild b/dev-util/mono-debugger/mono-debugger-2.0.ebuild
deleted file mode 100644
index 3a74c6eeea15..000000000000
--- a/dev-util/mono-debugger/mono-debugger-2.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.0.ebuild,v 1.3 2009/05/20 19:51:44 loki_val Exp $
-
-inherit eutils mono
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~x86 ~amd64"
-IUSE=""
-
-RDEPEND=">=dev-lang/mono-2.0
- sys-libs/readline"
-DEPEND="${RDEPEND}
- !dev-lang/mercury
- >=dev-util/pkgconfig-0.20"
-
-RESTRICT="test"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README ChangeLog AUTHORS NEWS
-}
diff --git a/dev-util/mono-debugger/mono-debugger-2.4.2-r1.ebuild b/dev-util/mono-debugger/mono-debugger-2.4.2-r1.ebuild
deleted file mode 100644
index 1c9a7ed25897..000000000000
--- a/dev-util/mono-debugger/mono-debugger-2.4.2-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.4.2-r1.ebuild,v 1.2 2010/02/05 09:52:13 aballier Exp $
-
-EAPI=2
-
-PATCHLEVEL=1
-
-inherit go-mono mono autotools flag-o-matic eutils
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-SRC_URI="${SRC_URI}
- mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS="-* ~x86 ~amd64"
-IUSE=""
-
-# Binutils is needed for libbfd
-RDEPEND="!!=dev-lang/mono-2.2
- >=dev-libs/libedit-20090111
- sys-devel/binutils
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-src_prepare() {
- go-mono_src_prepare
-
- epatch "${WORKDIR}/${P}-patches-${PATCHLEVEL}"/*
-
- eautoreconf
-}
-
-src_configure() {
- # Let's go for extra safety to avoid runtime errors, until
- # upstream applies it.
- append-ldflags -Wl,--no-undefined
-
- go-mono_src_configure \
- --with-system-libbfd \
- --with-system-libedit \
- --disable-static
-}
diff --git a/dev-util/mono-debugger/mono-debugger-2.4.2.ebuild b/dev-util/mono-debugger/mono-debugger-2.4.2.ebuild
deleted file mode 100644
index c35dc8b1facd..000000000000
--- a/dev-util/mono-debugger/mono-debugger-2.4.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.4.2.ebuild,v 1.2 2009/07/04 10:29:33 flameeyes Exp $
-
-EAPI=2
-
-inherit go-mono mono
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS="-* ~x86 ~amd64"
-IUSE=""
-
-RDEPEND="!!=dev-lang/mono-2.2
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-RESTRICT="test"
-
-src_configure() {
- go-mono_src_configure \
- --disable-static
-}
diff --git a/dev-util/mono-debugger/mono-debugger-2.4.9999.ebuild b/dev-util/mono-debugger/mono-debugger-2.4.9999.ebuild
deleted file mode 100644
index e35946ec6531..000000000000
--- a/dev-util/mono-debugger/mono-debugger-2.4.9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.4.9999.ebuild,v 1.5 2009/06/09 21:19:11 loki_val Exp $
-
-EAPI=2
-
-inherit go-mono mono
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="sys-libs/readline
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-RESTRICT="test"