summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.3.0.ebuild78
-rw-r--r--dev-util/eric/files/4.3.0-paths.patch33
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 70c5add5ac8f..d2d654669dc0 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.70 2009/02/07 13:52:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.71 2009/02/16 21:02:52 jokey Exp $
+
+*eric-4.3.0 (16 Feb 2009)
+
+ 16 Feb 2009; Markus Ullmann <jokey@gentoo.org> +files/4.3.0-paths.patch,
+ +eric-4.3.0.ebuild:
+ Version bump
*eric-4.2.5-r1 (07 Feb 2009)
diff --git a/dev-util/eric/eric-4.3.0.ebuild b/dev-util/eric/eric-4.3.0.ebuild
new file mode 100644
index 000000000000..b9eb820bf8e4
--- /dev/null
+++ b/dev-util/eric/eric-4.3.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.0.ebuild,v 1.1 2009/02/16 21:02:52 jokey Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4[svg]
+ >=dev-python/qscintilla-python-2.2[qt4]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/4.3.0-paths.patch
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-util/eric/files/4.3.0-paths.patch b/dev-util/eric/files/4.3.0-paths.patch
new file mode 100644
index 000000000000..697cbe513113
--- /dev/null
+++ b/dev-util/eric/files/4.3.0-paths.patch
@@ -0,0 +1,33 @@
+diff -urN ./eric4-4.3.0.orig/install.py ./eric4-4.3.0/install.py
+--- ./eric4-4.3.0.orig/install.py 2009-02-08 14:10:24.000000000 +0100
++++ ./eric4-4.3.0/install.py 2009-02-16 16:49:39.261427434 +0100
+@@ -190,7 +190,7 @@
+ fname = os.path.join(pdir, "__init__.py")
+ if not os.path.exists(fname):
+ if not os.path.exists(pdir):
+- os.mkdir(pdir, 0755)
++ os.makedirs(pdir, 0755)
+ f = open(fname, "wb")
+ f.write(\
+ '''# -*- coding: utf-8 -*-
+@@ -215,7 +215,10 @@
+ if not specialInstall and qtDataDir is None:
+ try:
+ from PyQt4 import pyqtconfig
+- qtDataDir = pyqtconfig._pkg_config["qt_data_dir"]
++ if distDir:
++ qtDataDir = distDir + pyqtconfig._pkg_config["qt_data_dir"]
++ else:
++ qtDataDir = pyqtconfig._pkg_config["qt_data_dir"]
+ except (AttributeError, ImportError):
+ print
+ print "Please enter the name of the Qt data directory."
+@@ -494,7 +497,7 @@
+ cfg['ericTemplatesDir'],
+ cfg['ericCodeTemplatesDir'], cfg['ericOthersDir'],
+ cfg['bindir'], cfg['mdir'],
+- getAPIsPath(), apis)
++ getAPIsPath()[len(distDir):], apis)
+ copyToFile(fn, config)
+
+ def doDependancyChecks():