summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccmalloc')
-rw-r--r--dev-util/ccmalloc/ChangeLog9
-rw-r--r--dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-util/ccmalloc/ChangeLog b/dev-util/ccmalloc/ChangeLog
index 9d310b317c84..fff69deb36de 100644
--- a/dev-util/ccmalloc/ChangeLog
+++ b/dev-util/ccmalloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccmalloc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ChangeLog,v 1.5 2008/10/20 14:20:39 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ChangeLog,v 1.6 2009/09/01 17:35:14 jer Exp $
+
+*ccmalloc-0.4.0-r2 (01 Sep 2009)
+
+ 01 Sep 2009; Jeroen Roovers <jer@gentoo.org> +ccmalloc-0.4.0-r2.ebuild:
+ Respect CC (bug #243978).
*ccmalloc-0.4.0-r1 (20 Oct 2008)
diff --git a/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild b/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..4d22bd10567b
--- /dev/null
+++ b/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild,v 1.1 2009/09/01 17:35:14 jer Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A easy-to-use memory debugging library"
+HOMEPAGE="http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/"
+SRC_URI="http://www.inf.ethz.ch/personal/biere/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS #240274
+ sed -i \
+ -e "s/CFLAGS=/CFLAGS+=/" \
+ Makefile.in || die "sed in Makefile.in failed"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use debug && myconf="${myconf} --debug"
+ # Not a standard configure script.
+ ./configure --prefix=/usr ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install || die "emake install failed"
+ dodoc BUGS FEATURES NEWS README TODO USAGE VERSION || die "dodoc failed"
+}