summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latex2html')
-rw-r--r--dev-tex/latex2html/ChangeLog13
-rw-r--r--dev-tex/latex2html/files/latex2html-convert-length.patch4
-rw-r--r--dev-tex/latex2html/files/latex2html-destdir.patch15
-rw-r--r--dev-tex/latex2html/latex2html-2008.ebuild80
4 files changed, 108 insertions, 4 deletions
diff --git a/dev-tex/latex2html/ChangeLog b/dev-tex/latex2html/ChangeLog
index 477acb597a9e..dba9be3c10f8 100644
--- a/dev-tex/latex2html/ChangeLog
+++ b/dev-tex/latex2html/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-tex/latex2html
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2html/ChangeLog,v 1.41 2007/10/14 21:43:06 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2html/ChangeLog,v 1.42 2008/10/31 22:02:46 aballier Exp $
+
+*latex2html-2008 (31 Oct 2008)
+
+ 31 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ files/latex2html-convert-length.patch, +files/latex2html-destdir.patch,
+ +latex2html-2008.ebuild:
+ Version bump. Remove files already provided by our latex installs, bug
+ #240980. Install latex files to texmf-site. Apply patch from bug #143831
+ to avoid using obsolete functions.
14 Oct 2007; Alexis Ballier <aballier@gentoo.org>
latex2html-2002.2.1_pre20041025-r1.ebuild:
diff --git a/dev-tex/latex2html/files/latex2html-convert-length.patch b/dev-tex/latex2html/files/latex2html-convert-length.patch
index 63506315d5c0..4171fd7c05e9 100644
--- a/dev-tex/latex2html/files/latex2html-convert-length.patch
+++ b/dev-tex/latex2html/files/latex2html-convert-length.patch
@@ -5,7 +5,7 @@
}
# should no longer be needed, as this is defined in latex2html.pin
-if (undefined &convert_length) { sub convert_length {&convert_length_table(@_)} }
-+if (undefined (&convert_length)) { sub convert_length {&convert_length_table(@_)} }
++if (!defined (&convert_length)) { sub convert_length {&convert_length_table(@_)} }
# Translates LaTeX column specifications to HTML. Again, Netscape
# needs some extra work with its width attributes in the <td> tags.
@@ -16,7 +16,7 @@
}
# should no longer be needed, as this is defined in latex2html.pin
-if (undefined &convert_length) { sub convert_length {&convert_length_table(@_)} }
-+if (undefined (&convert_length)) { sub convert_length {&convert_length_table(@_)} }
++if (!defined (&convert_length)) { sub convert_length {&convert_length_table(@_)} }
# Translates LaTeX column specifications to HTML. Again, Netscape
# needs some extra work with its width attributes in the <td> tags.
diff --git a/dev-tex/latex2html/files/latex2html-destdir.patch b/dev-tex/latex2html/files/latex2html-destdir.patch
new file mode 100644
index 000000000000..2d07beff449b
--- /dev/null
+++ b/dev-tex/latex2html/files/latex2html-destdir.patch
@@ -0,0 +1,15 @@
+Index: latex2html-2008/config/install.pl
+===================================================================
+--- latex2html-2008.orig/config/install.pl
++++ latex2html-2008/config/install.pl
+@@ -372,7 +372,9 @@ foreach $item (sort keys %Install_items)
+
+ if($cfg{TEXPATH}) {
+ print "\nNote: trying to install LaTeX2HTML style files in TeX directory tree\n ($cfg{TEXPATH})\n";
+- unless(mkpath($cfg{TEXPATH})) {
++ my $destdir = $cfg{TEXPATH};
++ $destdir = $ENV{'DESTDIR'}.$destdir if($ENV{'DESTDIR'});
++ unless(mkpath($destdir)) {
+ #my $testpath = $cfg{TEXPATH}; # to strip (latex2)html
+ #$testpath =~ s/[$dd$dd][^$dd$dd]*$//;
+ #if((-d $cfg{TEXPATH} && !-w _) || (-d $testpath && !-w _)) {
diff --git a/dev-tex/latex2html/latex2html-2008.ebuild b/dev-tex/latex2html/latex2html-2008.ebuild
new file mode 100644
index 000000000000..e6980d1a836a
--- /dev/null
+++ b/dev-tex/latex2html/latex2html-2008.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2html/latex2html-2008.ebuild,v 1.1 2008/10/31 22:02:46 aballier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="convertor written in Perl that converts LATEX documents to HTML"
+SRC_URI="http://saftsack.fs.uni-bayreuth.de/~latex2ht/current/${P}.tar.gz"
+HOMEPAGE="http://www.latex2html.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gif png"
+
+DEPEND="virtual/ghostscript
+ virtual/latex-base
+ media-libs/netpbm
+ dev-lang/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-convert-length.patch"
+ epatch "${FILESDIR}/${PN}-perl_name.patch"
+ epatch "${FILESDIR}/${PN}-extract-major-version.patch"
+ epatch "${FILESDIR}/${PN}-destdir.patch"
+ # Dont install old url.sty and other files
+ # Bug #240980
+ rm -f texinputs/url.sty texinputs/latin9.def || die "failed to remove duplicate latex files"
+}
+
+src_compile() {
+ local myconf
+
+ use gif || use png || myconf="${myconf} --disable-images"
+
+ econf --libdir=/usr/$(get_libdir)/latex2html \
+ --shlibdir=/usr/$(get_libdir)/latex2html \
+ --enable-pk \
+ --enable-eps \
+ --enable-reverse \
+ --enable-pipes \
+ --enable-paths \
+ --enable-wrapper \
+ --with-texpath=/usr/share/texmf-site/tex/latex/html \
+ --without-mktexlsr \
+ $(use_enable gif) \
+ $(use_enable png) \
+ ${myconf} || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc BUGS Changes FAQ LICENSE.orig MANIFEST README* TODO
+
+ # make /usr/share/latex2html sticky
+ keepdir /usr/share/latex2html
+
+ # clean the perl scripts up to remove references to the sandbox
+ einfo "fixing sandbox references"
+ dosed "s:${T}:/tmp:g" /usr/$(get_libdir)/latex2html/pstoimg.pl
+ dosed "s:${S}::g" /usr/$(get_libdir)/latex2html/latex2html.pl
+ dosed "s:${T}:/tmp:g" /usr/$(get_libdir)/latex2html/cfgcache.pm
+ dosed "s:${T}:/tmp:g" /usr/$(get_libdir)/latex2html/l2hconf.pm
+}
+
+pkg_postinst() {
+ einfo "Running ${ROOT}usr/bin/mktexlsr to rebuild ls-R database...."
+ "${ROOT}"usr/bin/mktexlsr
+}
+
+pkg_postrm() {
+ einfo "Running ${ROOT}usr/bin/mktexlsr to rebuild ls-R database...."
+ "${ROOT}"usr/bin/mktexlsr
+}