summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/sqlite3')
-rw-r--r--dev-ruby/sqlite3/ChangeLog6
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.7.ebuild71
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.8.ebuild76
3 files changed, 5 insertions, 148 deletions
diff --git a/dev-ruby/sqlite3/ChangeLog b/dev-ruby/sqlite3/ChangeLog
index a05fa0d40d5d..e7328ae0bab1 100644
--- a/dev-ruby/sqlite3/ChangeLog
+++ b/dev-ruby/sqlite3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/sqlite3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.12 2013/10/07 14:09:16 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.13 2013/11/02 20:25:05 mrueg Exp $
+
+ 02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -sqlite3-1.3.7.ebuild,
+ -sqlite3-1.3.8.ebuild:
+ Cleanup old.
*sqlite3-1.3.8-r1 (07 Oct 2013)
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.7.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.7.ebuild
deleted file mode 100644
index c2063e32f293..000000000000
--- a/dev-ruby/sqlite3/sqlite3-1.3.7.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.7.ebuild,v 1.1 2013/02/01 06:54:05 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="docs faq"
-RUBY_FAKEGEM_DOCDIR="doc faq"
-RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An extension library to access a SQLite database from Ruby"
-HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
-LICENSE="BSD"
-
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND+=" =dev-db/sqlite-3*"
-DEPEND+=" =dev-db/sqlite-3*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/hoe
- doc? ( dev-ruby/redcloth )"
-
-all_ruby_prepare() {
- # We remove the vendor_sqlite3 rake task because it's used to
- # bundle SQlite3 which we definitely don't want.
- rm tasks/vendor_sqlite3.rake || die
-
- sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/sqlite3 extconf.rb || die
-}
-
-each_ruby_compile() {
- # TODO: not sure what happens with jruby
-
- emake -Cext/sqlite3
- mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- # sqlite3 was called sqlite3-ruby before, so add a spec file that
- # simply loads sqlite3 to make sure that old projects load correctly
- # we don't even need to create a file to load this: the `require
- # sqlite3` was already part of sqlite3-ruby requirements.
- cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
-# generated by ebuild
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.7.ebuild,v 1.1 2013/02/01 06:54:05 graaff Exp $
-Gem::Specification.new do |s|
- s.name = "sqlite3-ruby"
- s.version = "${RUBY_FAKEGEM_VERSION}"
- s.summary = "Fake gem to load sqlite3"
- s.homepage = "${HOMEPAGE}"
- s.specification_version = 3
- s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
-end
-EOF
- RUBY_FAKEGEM_NAME=sqlite3-ruby \
- RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \
- ruby_fakegem_install_gemspec
-}
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.8.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.8.ebuild
deleted file mode 100644
index 1f503423b417..000000000000
--- a/dev-ruby/sqlite3/sqlite3-1.3.8.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.8.ebuild,v 1.1 2013/08/25 09:45:59 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="docs faq"
-RUBY_FAKEGEM_DOCDIR="doc faq"
-RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An extension library to access a SQLite database from Ruby"
-HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
-LICENSE="BSD"
-
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND+=" =dev-db/sqlite-3*"
-DEPEND+=" =dev-db/sqlite-3*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/hoe
- doc? ( dev-ruby/redcloth )
- test? ( dev-ruby/minitest:5 )"
-
-all_ruby_prepare() {
- # We remove the vendor_sqlite3 rake task because it's used to
- # bundle SQlite3 which we definitely don't want.
- rm tasks/vendor_sqlite3.rake || die
-
- # Remove license line from hoe to avoid depending on a newer
- # version.
- sed -i -e '/license/d' tasks/gem.rake || die
-
- sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/sqlite3 extconf.rb || die
-}
-
-each_ruby_compile() {
- # TODO: not sure what happens with jruby
-
- emake -Cext/sqlite3 V=1
- mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- # sqlite3 was called sqlite3-ruby before, so add a spec file that
- # simply loads sqlite3 to make sure that old projects load correctly
- # we don't even need to create a file to load this: the `require
- # sqlite3` was already part of sqlite3-ruby requirements.
- cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
-# generated by ebuild
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.8.ebuild,v 1.1 2013/08/25 09:45:59 graaff Exp $
-Gem::Specification.new do |s|
- s.name = "sqlite3-ruby"
- s.version = "${RUBY_FAKEGEM_VERSION}"
- s.summary = "Fake gem to load sqlite3"
- s.homepage = "${HOMEPAGE}"
- s.specification_version = 3
- s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
-end
-EOF
- RUBY_FAKEGEM_NAME=sqlite3-ruby \
- RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \
- ruby_fakegem_install_gemspec
-}