summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/turbojson/turbojson-1.1.2.ebuild')
-rw-r--r--dev-python/turbojson/turbojson-1.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/turbojson/turbojson-1.1.2.ebuild b/dev-python/turbojson/turbojson-1.1.2.ebuild
new file mode 100644
index 000000000000..60e9bd063dee
--- /dev/null
+++ b/dev-python/turbojson/turbojson-1.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbojson/turbojson-1.1.2.ebuild,v 1.1 2008/01/04 17:29:27 hawking Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=TurboJson
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="TurboGears JSON file format support plugin"
+HOMEPAGE="http://www.turbogears.org/docs/plugins/template.html"
+#SRC_URI="http://files.turbogears.org/eggs/${MY_P}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/T/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/ruledispatch
+ dev-python/simplejson"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "tests failed"
+}