summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild')
-rw-r--r--dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..95e593d92d5e
--- /dev/null
+++ b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild,v 1.1 2013/05/04 20:18:21 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P="yum-metadata-parser-${PV}"
+
+DESCRIPTION="sqlite cacher for python applications"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://yum.baseurl.org/download/yum-metadata-parser/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# glib and libxml2 are used via an extension module written in C.
+# No need to add PYTHON_USEDEP here.
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"