summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog6
-rw-r--r--dev-python/shiboken/files/rpath.cmake10
-rw-r--r--dev-python/shiboken/shiboken-1.1.1.ebuild8
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 87135c57bca6..d4010ef37a69 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.26 2012/05/29 15:41:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.27 2012/05/30 07:38:42 jlec Exp $
+
+ 30 May 2012; Justin Lecher <jlec@gentoo.org> shiboken-1.1.1.ebuild,
+ +files/rpath.cmake:
+ Add fix for prefix, missing rpath for qt4 installation
29 May 2012; Justin Lecher <jlec@gentoo.org> shiboken-1.1.1.ebuild:
Added ~-linux keywords, tested by me
diff --git a/dev-python/shiboken/files/rpath.cmake b/dev-python/shiboken/files/rpath.cmake
new file mode 100644
index 000000000000..b896c8789185
--- /dev/null
+++ b/dev-python/shiboken/files/rpath.cmake
@@ -0,0 +1,10 @@
+# use, i.e. don't skip the full RPATH for the build tree
+SET(CMAKE_SKIP_BUILD_RPATH FALSE)
+
+# when building, don't use the install RPATH already
+# (but later on when installing)
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+
+# add the automatically determined parts of the RPATH
+# which point to directories outside the build tree to the install RPATH
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
diff --git a/dev-python/shiboken/shiboken-1.1.1.ebuild b/dev-python/shiboken/shiboken-1.1.1.ebuild
index 723e61516da2..098e47b1ad85 100644
--- a/dev-python/shiboken/shiboken-1.1.1.ebuild
+++ b/dev-python/shiboken/shiboken-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.2 2012/05/29 15:41:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.3 2012/05/30 07:38:42 jlec Exp $
EAPI=4
@@ -40,6 +40,12 @@ src_prepare() {
# caused by the usage of a different version suffix with python >= 3.2
sed -i -e "/get_config_var('SOABI')/d" \
cmake/Modules/FindPython3InterpWithDebug.cmake || die
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake .
+ sed \
+ -i '1iinclude(rpath.cmake)' \
+ CMakeLists.txt || die
+ fi
}
src_configure() {