summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kaa-base/kaa-base-0.4.0.ebuild')
-rw-r--r--dev-python/kaa-base/kaa-base-0.4.0.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/kaa-base/kaa-base-0.4.0.ebuild b/dev-python/kaa-base/kaa-base-0.4.0.ebuild
index acc916d519f6..9e3004dbebd6 100644
--- a/dev-python/kaa-base/kaa-base-0.4.0.ebuild
+++ b/dev-python/kaa-base/kaa-base-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.4.0.ebuild,v 1.2 2008/08/16 14:43:06 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.4.0.ebuild,v 1.3 2008/08/16 15:36:49 rbu Exp $
inherit python eutils distutils
@@ -10,14 +10,15 @@ SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="sqlite lirc"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi ssl sqlite lirc"
RDEPEND="dev-libs/libxml2
dev-python/pynotifier
- dev-python/tlslite
+ avahi? ( net-dns/avahi )
+ lirc? ( dev-python/pylirc )
sqlite? ( >=dev-libs/glib-2.4.0 >=dev-python/pysqlite-2.2 )
- lirc? ( dev-python/pylirc )"
+ tls? ( dev-python/tlslite )"
PYTHON_MODNAME="kaa"
@@ -33,4 +34,8 @@ pkg_setup() {
eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
fi
+ if ! built_with_use net-dns/avahi python; then
+ eerror "net-dns/avahi must be built with the 'python' USE flag"
+ die "Recompile net-dns/avahi with the 'python' USE flag enabled"
+ fi
}