summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/sexplib')
-rw-r--r--dev-ml/sexplib/ChangeLog7
-rw-r--r--dev-ml/sexplib/sexplib-7.0.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index ecd75f3b61a0..a0e2489a1050 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.15 2012/03/27 21:08:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.16 2012/06/30 14:15:29 aballier Exp $
+
+*sexplib-7.0.5 (30 Jun 2012)
+
+ 30 Jun 2012; Alexis Ballier <aballier@gentoo.org> +sexplib-7.0.5.ebuild:
+ version bump
27 Mar 2012; Alexis Ballier <aballier@gentoo.org> sexplib-7.0.4.ebuild:
convert to oasis.eclass
diff --git a/dev-ml/sexplib/sexplib-7.0.5.ebuild b/dev-ml/sexplib/sexplib-7.0.5.ebuild
new file mode 100644
index 000000000000..4fbaa197eecc
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-7.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-7.0.5.ebuild,v 1.1 2012/06/30 14:15:29 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://forge.ocamlcore.org/projects/sexplib/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/832/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-ml/type-conv-3.0.5"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+DOCS=( "README.txt" "Changelog" )
+
+src_compile() {
+ oasis_src_compile
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ oasis_src_install
+
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}