summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/yajl/yajl-1.0.11.ebuild')
-rw-r--r--dev-libs/yajl/yajl-1.0.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-1.0.11.ebuild b/dev-libs/yajl/yajl-1.0.11.ebuild
new file mode 100644
index 000000000000..1704311895ef
--- /dev/null
+++ b/dev-libs/yajl/yajl-1.0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11.ebuild,v 1.1 2010/10/15 17:50:22 ssuominen Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CMAKE_IN_SOURCE_BUILD="1"
+
+src_prepare() {
+ cd "${WORKDIR}"/lloyd-${PN}-*
+ S=$(pwd)
+
+ epatch "${FILESDIR}"/${PN}-fix_tests.patch
+}
+
+src_test() {
+ emake test || die
+}