summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcgroup')
-rw-r--r--dev-libs/libcgroup/ChangeLog9
-rw-r--r--dev-libs/libcgroup/libcgroup-0.38.ebuild96
-rw-r--r--dev-libs/libcgroup/libcgroup-0.39_rc1.ebuild114
-rw-r--r--dev-libs/libcgroup/metadata.xml5
4 files changed, 223 insertions, 1 deletions
diff --git a/dev-libs/libcgroup/ChangeLog b/dev-libs/libcgroup/ChangeLog
index f73ec2a5a1db..7608b03225a1 100644
--- a/dev-libs/libcgroup/ChangeLog
+++ b/dev-libs/libcgroup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libcgroup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcgroup/ChangeLog,v 1.4 2012/10/07 08:57:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcgroup/ChangeLog,v 1.5 2012/11/26 18:45:24 maksbotan Exp $
+
+*libcgroup-0.38 (26 Nov 2012)
+*libcgroup-0.39_rc1 (26 Nov 2012)
+
+ 26 Nov 2012; Maxim Koltsov <maksbotan@gentoo.org> +libcgroup-0.38.ebuild,
+ +libcgroup-0.39_rc1.ebuild, metadata.xml:
+ Bump to 0.38 and 0.39-r1, bug #437856. Thanks to slepnoga
07 Oct 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, #24135.
diff --git a/dev-libs/libcgroup/libcgroup-0.38.ebuild b/dev-libs/libcgroup/libcgroup-0.38.ebuild
new file mode 100644
index 000000000000..39b10904d0bc
--- /dev/null
+++ b/dev-libs/libcgroup/libcgroup-0.38.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcgroup/libcgroup-0.38.ebuild,v 1.1 2012/11/26 18:45:24 maksbotan Exp $
+
+EAPI="4"
+
+inherit autotools eutils linux-info pam
+
+DESCRIPTION="Tools and libraries to configure and manage kernel control groups"
+HOMEPAGE="http://libcg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libcg/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+daemon debug pam static-libs +tools"
+
+RDEPEND="pam? ( virtual/pam )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ if use daemon && ! use tools; then
+ eerror "The daemon USE flag requires tools USE flag."
+ die "Please enable tools or disable daemon."
+ fi
+
+ local CONFIG_CHECK="~CGROUPS"
+ if use daemon; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CONNECTOR ~PROC_EVENTS"
+ fi
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ # Change rules file location
+ sed -e 's:/etc/cgrules.conf:/etc/cgroup/cgrules.conf:' \
+ -i src/libcgroup-internal.h || die "sed failed"
+ sed -e 's:\(pam_cgroup_la_LDFLAGS.*\):\1\ -avoid-version:' \
+ -i src/pam/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ my_conf="--enable-shared
+ --libdir=/usr/$(get_libdir)
+ $(use_enable daemon)
+ $(use_enable debug)
+ $(use_enable pam)
+ $(use_enable static-libs static)
+ $(use_enable tools)"
+
+ if use pam; then
+ my_conf="${my_conf} --enable-pam-module-dir=$(getpam_mod_dir)"
+ fi
+
+ econf ${my_conf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ find "${D}" -name "*.la" -delete || die "la removal failed"
+
+ insinto /etc/cgroup
+ doins samples/cgrules.conf || die
+
+ if use tools; then
+ doins samples/cgconfig.conf || die
+
+ newconfd "${FILESDIR}"/cgconfig.confd cgconfig || die
+ newinitd "${FILESDIR}"/cgconfig.initd cgconfig || die
+ fi
+
+ if use daemon; then
+ newconfd "${FILESDIR}"/cgred.confd cgred || die
+ newinitd "${FILESDIR}"/cgred.initd cgred || die
+ fi
+}
+
+pkg_postinst() {
+ elog "Read the kernel docs on cgroups, related schedulers, and the"
+ elog "block I/O controllers. The Redhat Resource Management Guide"
+ elog "is also helpful. DO NOT enable the cgroup namespace subsytem"
+ elog "if you want a custom config, rule processing, etc. This option"
+ elog "should only be enabled for a VM environment. The UID wildcard"
+ elog "rules seem to work only without a custom config (since wildcards"
+ elog "don't work in config blocks). Specific user-id configs *do*"
+ elog "work, but be careful about how the mem limits add up if using"
+ elog "the memory.limit_* directives. There should be a basic task"
+ elog "partitioning into the default group when running cgred with no"
+ elog "specific config blocks or rules (other than the mount directive)."
+ elog "See the docs for the pam module config, and as always, RTFM..."
+}
diff --git a/dev-libs/libcgroup/libcgroup-0.39_rc1.ebuild b/dev-libs/libcgroup/libcgroup-0.39_rc1.ebuild
new file mode 100644
index 000000000000..0830f2c39634
--- /dev/null
+++ b/dev-libs/libcgroup/libcgroup-0.39_rc1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcgroup/libcgroup-0.39_rc1.ebuild,v 1.1 2012/11/26 18:45:23 maksbotan Exp $
+
+EAPI="4"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils linux-info pam autotools-utils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 .)"
+
+DESCRIPTION="Tools and libraries to configure and manage kernel control groups"
+HOMEPAGE="http://libcg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/libcg/${PN}/v0.39.rc/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+daemon debug pam static-libs +tools debug"
+
+RDEPEND="pam? ( virtual/pam )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+REQUIRED_USE="daemon? ( tools )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(README_daemon README README_systemd INSTALL)
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS"
+ if use daemon; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CONNECTOR ~PROC_EVENTS"
+ fi
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+
+ # Change rules file location
+ sed -e 's:/etc/cgrules.conf:/etc/cgroup/cgrules.conf:' \
+ -i src/libcgroup-internal.h || die "sed failed"
+ sed -e 's:\(pam_cgroup_la_LDFLAGS.*\):\1\ -avoid-version:' \
+ -i src/pam/Makefile.am || die "sed failed"
+ sed -e 's#/var/run#/run#g' -i configure.in || die "sed failed"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local my_conf
+
+ if use pam; then
+ my_conf=" --enable-pam-module-dir=$(getpam_mod_dir) "
+ fi
+
+ #if use daemon; then
+ # my_conf+=" --enable-cgred-socket=/run/cgred.socket "
+ #fi
+
+ local myeconfargs=(
+ $(use_enable daemon)
+ $(use_enable debug)
+ $(use_enable pam)
+ $(use_enable tools)
+ --enable-silent-rules
+ ${my_conf}
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # Use mount cgroup to build directory
+ # sandbox restricted to trivial build,
+ # possible kill Diego tanderbox ;)
+ true
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+
+ insinto /etc/cgroup
+ doins samples/*.conf || die
+
+ if use tools; then
+ newconfd "${FILESDIR}"/cgconfig.confd cgconfig || die
+ newinitd "${FILESDIR}"/cgconfig.initd cgconfig || die
+ fi
+
+ if use daemon; then
+ newconfd "${FILESDIR}"/cgred.confd cgred || die
+ newinitd "${FILESDIR}"/cgred.initd cgred || die
+ fi
+}
+
+pkg_postinst() {
+ elog "Read the kernel docs on cgroups, related schedulers, and the"
+ elog "block I/O controllers. The Redhat Resource Management Guide"
+ elog "is also helpful. DO NOT enable the cgroup namespace subsytem"
+ elog "if you want a custom config, rule processing, etc. This option"
+ elog "should only be enabled for a VM environment. The UID wildcard"
+ elog "rules seem to work only without a custom config (since wildcards"
+ elog "don't work in config blocks). Specific user-id configs *do*"
+ elog "work, but be careful about how the mem limits add up if using"
+ elog "the memory.limit_* directives. There should be a basic task"
+ elog "partitioning into the default group when running cgred with no"
+ elog "specific config blocks or rules (other than the mount directive)."
+ elog "See the docs for the pam module config, and as always, RTFM..."
+}
diff --git a/dev-libs/libcgroup/metadata.xml b/dev-libs/libcgroup/metadata.xml
index e9718aa94404..c715643b8d4a 100644
--- a/dev-libs/libcgroup/metadata.xml
+++ b/dev-libs/libcgroup/metadata.xml
@@ -2,6 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>dev-tools</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ </maintainer>
<longdescription>
This package provides configuration and command-line tools, as well as a rules
processing daemon for working with kernel control groups.