summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/json-glib/json-glib-0.12.6.ebuild')
-rw-r--r--dev-libs/json-glib/json-glib-0.12.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/json-glib/json-glib-0.12.6.ebuild b/dev-libs/json-glib/json-glib-0.12.6.ebuild
new file mode 100644
index 000000000000..0d29a2709c8d
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-0.12.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-glib/json-glib-0.12.6.ebuild,v 1.1 2011/06/16 07:44:43 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library providing GLib serialization and deserialization support for the JSON format"
+HOMEPAGE="http://live.gnome.org/JsonGlib"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +introspection"
+
+RDEPEND=">=dev-libs/glib-2.16:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # Coverage support is useless, and causes runtime problems
+ G2CONF="${G2CONF}
+ --disable-coverage
+ $(use_enable introspection)"
+}