summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-1.8.8.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 69270d051b21..5425ccc79913 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -2,6 +2,5 @@ AUX botan-1.8.8-darwin-install_name-fix.patch 511 RMD160 40f5e7361f991de21ca0599
AUX botan-1.8.8-use_negative_lea_displacement.patch 884 RMD160 c259f4d51f3c25df93d2cf99f9f29d6f2f92ea5d SHA1 d5b3deec6fadaea2b2fc41e3b62ca38c8c007f16 SHA256 b88d8a5af5a849e7a0ecbce70d63f5348cb15fd156440080e6f8e6d569084784
DIST Botan-1.8.8.tgz 2844588 RMD160 f8ac1842ddba312903442038d32da57f25f9bc1b SHA1 699df8f0c5e8d48fa8c65a873bb2e9975d4d66c5 SHA256 60a31bd9ed18ac85293d7f44c7fbb9bd0206eb7df5b42dff8517dd01b446ba84
EBUILD botan-1.8.8-r1.ebuild 2545 RMD160 bf8adc409539138c015854cf3ae625de9c6f2017 SHA1 d8d55ce0b1edcd6846f244813b86a4df77835e09 SHA256 f5fabda52dfa1e13f6a7049e67d0162ea71f3c982b42036e5de8742fb3714ccf
-EBUILD botan-1.8.8.ebuild 2211 RMD160 67cd9ac6e2c3fdfa0498ad944e2944459dae5104 SHA1 62036e8eebcfff6a0c3e91f3b477f3687e678682 SHA256 da9a455d28890b88eb0fd79bcd15eca48cd2598f92a2e3a44ed2ac12de1f4d34
MISC ChangeLog 9370 RMD160 2864d801d065e552ae0501e07848abdef019f971 SHA1 e0d308960b4adfc764139ff5eab5b73a4f15e5ca SHA256 f4c1a0cf7b53ff569f060c8f723000ebfe931cc573821646883211c2a70908a3
MISC metadata.xml 319 RMD160 084032a656409b8d666fa6e9c0b0f89e3ef955e7 SHA1 77d4f800c80c56a3191d488ef2d6444ab165cee3 SHA256 c0597f70f00af70ca6f77bf906babe3059717b8c1e91a74c61904008e0c14054
diff --git a/dev-libs/botan/botan-1.8.8.ebuild b/dev-libs/botan/botan-1.8.8.ebuild
deleted file mode 100644
index d6ad4d6acb1b..000000000000
--- a/dev-libs/botan/botan-1.8.8.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.8.ebuild,v 1.5 2010/02/04 04:20:51 hwoarang Exp $
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://files.randombit.net/botan/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bzip2 gmp ssl threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- gmp? ( >=dev-libs/gmp-4.2.2 )
- ssl? ( >=dev-libs/openssl-0.9.8g )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/python-2.4"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-use_negative_lea_displacement.patch"
-}
-
-src_configure() {
- local disable_modules="proc_walk,unix_procs,cpu_counter"
-
- if ! useq threads; then
- disable_modules="${disable_modules},pthreads"
- fi
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- cd "${S}"
- elog "Disabling modules: ${disable_modules}"
-
- # FIXME: We might actually be on *BSD or OS X...
- ./configure.py \
- --prefix="${D}/usr" \
- --libdir=/$(get_libdir) \
- --docdir=/share/doc/ \
- --cc=gcc \
- --os=linux \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --with-tr1=system \
- $(use_with bzip2) \
- $(use_with gmp gnump) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- --disable-modules=${disable_modules} \
- || die "configure.py failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
- LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
- emake install || die "emake install failed"
- sed -i -e "s:${D}::g" "${D}usr/bin/botan-config" "${D}usr/$(get_libdir)/pkgconfig/botan-1.8.pc" || die "sed failed"
- mv "${D}usr/share/doc/Botan-${PV}" "${D}usr/share/doc/${PF}" || die "Renaming of directory failed"
-}