summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog5
-rw-r--r--dev-lang/ocaml/ocaml-3.10.2.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 4a463e5c637e..900ec0af6641 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.168 2009/06/20 16:12:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.169 2009/08/01 23:11:57 flameeyes Exp $
+
+ 01 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org> ocaml-3.10.2.ebuild:
+ Use -j1 for make. Bug #279968.
20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.1.ebuild:
use CHOST prefixed toolchain for building, this does not give us cross
diff --git a/dev-lang/ocaml/ocaml-3.10.2.ebuild b/dev-lang/ocaml/ocaml-3.10.2.ebuild
index 7e888f634f0b..99d65be5c480 100644
--- a/dev-lang/ocaml/ocaml-3.10.2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.14 2009/05/19 23:12:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.15 2009/08/01 23:11:57 flameeyes Exp $
EAPI="1"
@@ -85,7 +85,8 @@ src_compile() {
--mandir /usr/share/man \
--with-pthread ${myconf} || die "configure failed!"
- make world || die "make world failed!"
+ # bug #279968
+ emake -j1 world || die "make world failed!"
# Native code generation can be disabled now
if use ocamlopt ; then