summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.11.1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index ec80170066b4..29562c3edde4 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.170 2009/08/02 12:19:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.171 2009/09/19 09:36:28 aballier Exp $
+
+ 19 Sep 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.1.ebuild:
+ Filter fomit-frame-pointer, ocaml builds some programs with -pg which
+ causes build failures with fomit-frame-pointer, bug #270920
02 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org> ocaml-3.10.2.ebuild:
Use serial make everywhere until fixed.
diff --git a/dev-lang/ocaml/ocaml-3.11.1.ebuild b/dev-lang/ocaml/ocaml-3.11.1.ebuild
index a0ba2b86a2b3..6b603c53bfc3 100644
--- a/dev-lang/ocaml/ocaml-3.11.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.3 2009/06/20 16:12:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.4 2009/09/19 09:36:28 aballier Exp $
EAPI="1"
@@ -49,6 +49,10 @@ src_compile() {
export LC_ALL=C
local myconf=""
+ # Causes build failures because it builds some programs with -pg,
+ # bug #270920
+ filter-flags -fomit-frame-pointer
+
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"