summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua/files')
-rw-r--r--dev-lang/lua/files/digest-lua-5.0.33
-rw-r--r--dev-lang/lua/files/lua-5.0.3-asneeded.patch11
-rw-r--r--dev-lang/lua/files/lua-5.0.3-ldflags.patch35
-rw-r--r--dev-lang/lua/files/lua-5.0.3-linking.patch13
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-lang/lua/files/digest-lua-5.0.3 b/dev-lang/lua/files/digest-lua-5.0.3
new file mode 100644
index 000000000000..b3c83fe64eaa
--- /dev/null
+++ b/dev-lang/lua/files/digest-lua-5.0.3
@@ -0,0 +1,3 @@
+MD5 feee27132056de2949ce499b0ef4c480 lua-5.0.3.tar.gz 191384
+RMD160 cb3ed4320b438d73c8ff6c93a02275c9fb461883 lua-5.0.3.tar.gz 191384
+SHA256 1193a61b0e08acaa6eee0eecf29709179ee49c71baebc59b682a25c3b5a45671 lua-5.0.3.tar.gz 191384
diff --git a/dev-lang/lua/files/lua-5.0.3-asneeded.patch b/dev-lang/lua/files/lua-5.0.3-asneeded.patch
new file mode 100644
index 000000000000..71e1a10090a0
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.0.3-asneeded.patch
@@ -0,0 +1,11 @@
+--- lua-5.0.3/Makefile.old 2006-10-04 15:21:15.116128747 +0200
++++ lua-5.0.3/Makefile 2006-10-04 15:23:57.340019809 +0200
+@@ -39,7 +39,7 @@
+ # shared libraries (for Linux)
+ so:
+ $(CC) $(LDFLAGS) -o lib/liblua.so.$V -shared -Wl,-soname,liblua.so.$V src/*.o
+- $(CC) $(LDFLAGS) -o lib/liblualib.so.$V -shared -Wl,-soname,liblualib.so.$V src/lib/*.o
++ $(CC) $(LDFLAGS) -o lib/liblualib.so.$V -shared -Wl,-soname,liblualib.so.$V src/lib/*.o -L$(LIB) -llua $(EXTRA_LIBS) $(DLLIB)
+ cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
+
+ # binaries using shared libraries
diff --git a/dev-lang/lua/files/lua-5.0.3-ldflags.patch b/dev-lang/lua/files/lua-5.0.3-ldflags.patch
new file mode 100644
index 000000000000..5bb3dad7ea97
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.0.3-ldflags.patch
@@ -0,0 +1,35 @@
+--- lua-5.0.3/Makefile.old 2006-10-04 13:23:13.253194162 +0200
++++ lua-5.0.3/Makefile 2006-10-04 13:23:02.727331000 +0200
+@@ -38,8 +38,8 @@
+
+ # shared libraries (for Linux)
+ so:
+- $(CC) -o lib/liblua.so.$V -shared -Wl,-soname,liblua.so.$V src/*.o
+- $(CC) -o lib/liblualib.so.$V -shared -Wl,-soname,liblualib.so.$V src/lib/*.o
++ $(CC) $(LDFLAGS) -o lib/liblua.so.$V -shared -Wl,-soname,liblua.so.$V src/*.o
++ $(CC) $(LDFLAGS) -o lib/liblualib.so.$V -shared -Wl,-soname,liblualib.so.$V src/lib/*.o
+ cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
+
+ # binaries using shared libraries
+--- lua-5.0.3/src/lua/Makefile.old 2006-10-04 13:07:11.250700357 +0200
++++ lua-5.0.3/src/lua/Makefile 2006-10-04 13:22:29.323765252 +0200
+@@ -13,7 +13,7 @@
+ all: $T
+
+ $T: $(OBJS) $(LIB)/liblua.a $(LIB)/liblualib.a
+- $(CC) -o $@ $(MYLDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
++ $(CC) -o $@ $(MYLDFLAGS) $(LDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
+
+ $(LIB)/liblua.a:
+ cd ..; $(MAKE)
+--- lua-5.0.3/src/luac/Makefile.old 2006-10-04 13:07:28.039482100 +0200
++++ lua-5.0.3/src/luac/Makefile 2006-10-04 13:22:45.059560684 +0200
+@@ -13,7 +13,7 @@
+ all: $T
+
+ $T: $(OBJS) $(LIB)/liblua.a $(LIB)/liblualib.a
+- $(CC) -o $@ $(MYLDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
++ $(CC) -o $@ $(MYLDFLAGS) $(LDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
+
+ # print.c needs opcode names from lopcodes.c
+ lopcodes.o: ../lopcodes.c ../lopcodes.h
diff --git a/dev-lang/lua/files/lua-5.0.3-linking.patch b/dev-lang/lua/files/lua-5.0.3-linking.patch
new file mode 100644
index 000000000000..784aa3d802b7
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.0.3-linking.patch
@@ -0,0 +1,13 @@
+--- lua-5.0.3/Makefile.old 2006-10-04 12:03:57.117024736 +0200
++++ lua-5.0.3/Makefile 2006-10-04 12:05:18.295969396 +0200
+@@ -38,8 +38,8 @@
+
+ # shared libraries (for Linux)
+ so:
+- ld -o lib/liblua.so.$V -shared src/*.o
+- ld -o lib/liblualib.so.$V -shared src/lib/*.o
++ $(CC) -o lib/liblua.so.$V -shared -Wl,-soname,liblua.so.$V src/*.o
++ $(CC) -o lib/liblualib.so.$V -shared -Wl,-soname,liblualib.so.$V src/lib/*.o
+ cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
+
+ # binaries using shared libraries