summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/ChangeLog7
-rw-r--r--dev-lang/lazarus/lazarus-1.0.10.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-lang/lazarus/ChangeLog b/dev-lang/lazarus/ChangeLog
index 3915e292310c..2b93b7e69d3e 100644
--- a/dev-lang/lazarus/ChangeLog
+++ b/dev-lang/lazarus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lazarus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.35 2013/01/31 08:15:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.36 2013/06/26 20:14:11 hasufell Exp $
+
+*lazarus-1.0.10 (26 Jun 2013)
+
+ 26 Jun 2013; Julian Ospald <hasufell@gentoo.org> +lazarus-1.0.10.ebuild:
+ version bump
*lazarus-1.0.4 (31 Jan 2013)
diff --git a/dev-lang/lazarus/lazarus-1.0.10.ebuild b/dev-lang/lazarus/lazarus-1.0.10.ebuild
new file mode 100644
index 000000000000..36733d545e18
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-1.0.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-1.0.10.ebuild,v 1.1 2013/06/26 20:14:11 hasufell Exp $
+
+EAPI=2
+
+inherit eutils
+
+RESTRICT="strip" #269221
+
+FPCVER="2.6.0"
+
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~ppc ~x86"
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+IUSE=""
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/lazarus-1.0.10-0.tar.gz"
+
+DEPEND=">=dev-lang/fpc-${FPCVER}[source]
+ net-misc/rsync
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ !=gnome-base/librsvg-2.16.1"
+DEPEND="${DEPEND}
+ >=sys-devel/binutils-2.19.1-r1"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set} ; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ #sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${D}"usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+ dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+ dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
+}