summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gdl')
-rw-r--r--dev-lang/gdl/ChangeLog12
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch40
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch12
-rw-r--r--dev-lang/gdl/gdl-0.9_rc1.ebuild4
-rw-r--r--dev-lang/gdl/gdl-0.9_rc2.ebuild98
5 files changed, 162 insertions, 4 deletions
diff --git a/dev-lang/gdl/ChangeLog b/dev-lang/gdl/ChangeLog
index dffca6817033..082e0abf2603 100644
--- a/dev-lang/gdl/ChangeLog
+++ b/dev-lang/gdl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/gdl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.11 2008/09/02 09:32:03 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.12 2009/08/26 02:46:16 markusle Exp $
+
+*gdl-0.9_rc2 (25 Aug 2009)
+
+ 25 Aug 2009; Markus Dittrich <markusle@gentoo.org> +gdl-0.9_rc2.ebuild,
+ +files/gdl-0.9_rc2-gcc4.4.patch, +files/gdl-0.9_rc2-antlr.patch:
+ Version bump and fixed hdf5-1.8 issue (see bug #275388).
+ Also, the ebuild now compiles against the system antlr fixing
+ the file collision with dev-java/antlr (see bug #267671).
02 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/gdl-0.8.11-gcc4-gentoo.patch, -files/gdl-0.9_pre5-proj4.patch,
diff --git a/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch b/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch
new file mode 100644
index 000000000000..b644eb2154df
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch
@@ -0,0 +1,40 @@
+diff -Naur gdl-0.9rc2/configure.in gdl-0.9rc2.new/configure.in
+--- gdl-0.9rc2/configure.in 2009-01-22 17:31:48.000000000 -0500
++++ gdl-0.9rc2.new/configure.in 2009-08-25 18:38:10.000000000 -0400
+@@ -755,7 +755,7 @@
+ dnl perform program name transformation
+ dnl AC_ARG_PROGRAM
+
+-AC_CONFIG_FILES(Makefile src/Makefile src/antlr/Makefile)
++AC_CONFIG_FILES(Makefile src/Makefile)
+
+ AC_OUTPUT
+
+diff -Naur gdl-0.9rc2/src/Makefile.am gdl-0.9rc2.new/src/Makefile.am
+--- gdl-0.9rc2/src/Makefile.am 2009-01-20 14:33:56.000000000 -0500
++++ gdl-0.9rc2.new/src/Makefile.am 2009-08-25 21:36:55.000000000 -0400
+@@ -1,6 +1,6 @@
+ # set the include path found by configure
+ INCLUDES = $(EXT_INCLUDES) $(all_includes)
+-SUBDIRS = antlr
++SUBDIRS =
+ noinst_HEADERS = gdlwidget.hpp prognode.hpp prognodeexpr.hpp
+
+ cpp_hpp_files = accessdesc.hpp arrayindex.hpp assocdata.cpp assocdata.hpp \
+@@ -53,7 +53,7 @@
+ gdl_CXXFLAGS = $(AM_CXXFLAGS)
+ # the library search path.
+ gdl_LDFLAGS = $(all_libraries)
+-gdl_LDADD = $(top_builddir)/src/antlr/libantlr.a -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++gdl_LDADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
+ # build as library (for python module)
+@@ -69,6 +69,6 @@
+ libgdl_la_LDFLAGS = $(all_libraries) -Wl,-z,muldefs
+ endif
+
+-libgdl_la_LIBADD = $(top_builddir)/src/antlr/libantlr.la -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++libgdl_la_LIBADD = -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
diff --git a/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch b/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch
new file mode 100644
index 000000000000..1acd9cf58f7c
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch
@@ -0,0 +1,12 @@
+diff -Naur gdl-0.9rc2/src/envt.hpp gdl-0.9rc2.new/src/envt.hpp
+--- gdl-0.9rc2/src/envt.hpp 2009-01-20 14:33:56.000000000 -0500
++++ gdl-0.9rc2.new/src/envt.hpp 2009-08-25 22:18:44.000000000 -0400
+@@ -508,6 +508,8 @@
+ void AssureStringScalarPar( SizeT ix, DString& scalar);
+
+ // to be extended on demand for other data types
++
++ friend class DInterpreter;
+ };
+
+
diff --git a/dev-lang/gdl/gdl-0.9_rc1.ebuild b/dev-lang/gdl/gdl-0.9_rc1.ebuild
index 21f51e8cd113..9e1cbbf065d2 100644
--- a/dev-lang/gdl/gdl-0.9_rc1.ebuild
+++ b/dev-lang/gdl/gdl-0.9_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9_rc1.ebuild,v 1.4 2008/06/06 15:56:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9_rc1.ebuild,v 1.5 2009/08/26 02:46:16 markusle Exp $
inherit eutils flag-o-matic autotools
diff --git a/dev-lang/gdl/gdl-0.9_rc2.ebuild b/dev-lang/gdl/gdl-0.9_rc2.ebuild
new file mode 100644
index 000000000000..49349058a771
--- /dev/null
+++ b/dev-lang/gdl/gdl-0.9_rc2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9_rc2.ebuild,v 1.1 2009/08/26 02:46:16 markusle Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic autotools
+
+MYP=${P/_/}
+DESCRIPTION="An Interactive Data Language compatible incremental compiler"
+LICENSE="GPL-2"
+HOMEPAGE="http://gnudatalanguage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnudatalanguage/${MYP}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python fftw hdf hdf5 netcdf imagemagick proj"
+
+RDEPEND=">=sys-libs/readline-4.3
+ sci-libs/gsl
+ =dev-java/antlr-2.7*[cxx]
+ >=sci-libs/plplot-5.3
+ imagemagick? ( media-gfx/imagemagick )
+ hdf? ( sci-libs/hdf )
+ hdf5? ( sci-libs/hdf5 )
+ netcdf? ( sci-libs/netcdf )
+ python? ( dev-python/numarray dev-python/matplotlib )
+ fftw? ( >=sci-libs/fftw-3 )
+ proj? ( sci-libs/proj )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9_rc1-proj4.patch
+ epatch "${FILESDIR}"/${PN}-0.9_rc1-magick.patch
+ epatch "${FILESDIR}"/${P}-gcc4.4.patch
+ epatch "${FILESDIR}"/${P}-antlr.patch
+
+ # we need to blow away the directory with antlr
+ # otherwise the build system picks up bogus
+ # header files
+ rm -fr "${S}"/src/antlr || die "failed to remove antlr directory"
+
+ eautoreconf
+}
+
+src_configure() {
+ # need to check for old plplot
+ local myconf
+ if has_version '<sci-libs/plplot-5.9.0'; then
+ myconf="${myconf} --enable-oldplplot"
+ fi
+
+ # sorry, but even configure barfs with --as-needed
+ # when linking against imagemagick - have yet to
+ # figure out what the problem is
+ use imagemagick && append-ldflags -Wl,--no-as-needed
+
+ # make sure we're hdf5-1.6 backward compatible
+ use hdf5 && append-flags -DH5_USE_16_API
+
+ use proj && append-cppflags -DPJ_LIB__
+ econf \
+ $(use_with python) \
+ $(use_with fftw) \
+ $(use_with hdf) \
+ $(use_with hdf5) \
+ $(use_with netcdf) \
+ $(use_with imagemagick Magick) \
+ $(use_with proj libproj4) \
+ ${myconf} \
+ || die "econf failed"
+
+}
+
+src_test() {
+ cd "${S}"/testsuite
+ PATH="${S}"/src gdl <<-EOF
+ test_suite
+ EOF
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ doins -r src/pro src/py || die "install pro and py files failed"
+ dodoc README PYTHON.txt AUTHORS ChangeLog NEWS TODO HACKING \
+ || die "Failed to install docs"
+
+ # add GDL provided routines to IDL_PATH
+ echo "GDL_STARTUP=/usr/share/${PN}/pro" > 99gdl
+ echo "GDL_PATH=/usr/share/${PN}" >> 99gdl
+ doenvd 99gdl || die "doenvd failed"
+}