summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/gpsim/ChangeLog6
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.21.11-gcc41.patch61
-rw-r--r--dev-embedded/gpsim/gpsim-0.21.11.ebuild6
3 files changed, 70 insertions, 3 deletions
diff --git a/dev-embedded/gpsim/ChangeLog b/dev-embedded/gpsim/ChangeLog
index 46b0aa4a2265..1be9257086ec 100644
--- a/dev-embedded/gpsim/ChangeLog
+++ b/dev-embedded/gpsim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-embedded/gpsim
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.18 2006/03/25 06:12:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.19 2006/03/25 21:21:52 flameeyes Exp $
+
+ 25 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/gpsim-0.21.11-gcc41.patch, gpsim-0.21.11.ebuild:
+ Add patch to build with GCC 4.1.
*gpsim-0.21.11 (25 Mar 2006)
*gpsim-0.21.2-r1 (25 Mar 2006)
diff --git a/dev-embedded/gpsim/files/gpsim-0.21.11-gcc41.patch b/dev-embedded/gpsim/files/gpsim-0.21.11-gcc41.patch
new file mode 100644
index 000000000000..e49ae99d6f9c
--- /dev/null
+++ b/dev-embedded/gpsim/files/gpsim-0.21.11-gcc41.patch
@@ -0,0 +1,61 @@
+Index: gpsim-0.21.11/cli/ui_gpsim.cc
+===================================================================
+--- gpsim-0.21.11.orig/cli/ui_gpsim.cc
++++ gpsim-0.21.11/cli/ui_gpsim.cc
+@@ -34,7 +34,7 @@ public:
+ CGpsimUserInterface(const char *paStrings[]);
+ virtual ~CGpsimUserInterface() {}
+
+- void CGpsimUserInterface::SetStreams(FILE *in, FILE *out);
++ void SetStreams(FILE *in, FILE *out);
+ virtual ISimConsole &GetConsole();
+ virtual void DisplayMessage(unsigned int uStringID, ...);
+ virtual void DisplayMessage(FILE * pOut, unsigned int uStringID, ...);
+Index: gpsim-0.21.11/src/p12x.h
+===================================================================
+--- gpsim-0.21.11.orig/src/p12x.h
++++ gpsim-0.21.11/src/p12x.h
+@@ -108,7 +108,7 @@ class P12CE518 : public P12C508
+
+ virtual PROCESSOR_TYPE isa(void){return _P12CE518_;};
+ virtual void tris_instruction(unsigned int tris_register);
+- virtual void P12CE518::set_eeprom(I2C_EE *e);
++ virtual void set_eeprom(I2C_EE *e);
+
+ P12CE518(void);
+ static Processor *construct(void);
+Index: gpsim-0.21.11/src/value.h
+===================================================================
+--- gpsim-0.21.11.orig/src/value.h
++++ gpsim-0.21.11/src/value.h
+@@ -290,7 +290,7 @@ public:
+
+ bool getVal() { return value; }
+
+- static Boolean* Boolean::typeCheck(Value* val, string valDesc);
++ static Boolean* typeCheck(Value* val, string valDesc);
+ virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
+
+ virtual Value *copy() { return new Boolean(value); }
+@@ -353,9 +353,9 @@ public:
+ virtual char *toString(char *, int len);
+ virtual char *toBitStr(char *, int len);
+
+- static Integer* Integer::typeCheck(Value* val, string valDesc);
+- static Integer* Integer::assertValid(Value* val, string valDesc, gint64 valMin);
+- static Integer* Integer::assertValid(Value* val, string valDesc, gint64 valMin, gint64 valMax);
++ static Integer* typeCheck(Value* val, string valDesc);
++ static Integer* assertValid(Value* val, string valDesc, gint64 valMin);
++ static Integer* assertValid(Value* val, string valDesc, gint64 valMin, gint64 valMax);
+ virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
+
+ inline operator gint64() {
+@@ -498,7 +498,7 @@ public:
+ /// copy the object value to a user char array
+ virtual char *toString(char *, int len);
+
+- static AbstractRange* AbstractRange::typeCheck(Value* val, string valDesc);
++ static AbstractRange* typeCheck(Value* val, string valDesc);
+ virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
+
+ private:
diff --git a/dev-embedded/gpsim/gpsim-0.21.11.ebuild b/dev-embedded/gpsim/gpsim-0.21.11.ebuild
index 100d35e003ca..ae8f9c7e95bd 100644
--- a/dev-embedded/gpsim/gpsim-0.21.11.ebuild
+++ b/dev-embedded/gpsim/gpsim-0.21.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.21.11.ebuild,v 1.2 2006/03/25 21:10:19 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.21.11.ebuild,v 1.3 2006/03/25 21:21:54 flameeyes Exp $
-inherit gnuconfig
+inherit gnuconfig eutils
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html"
@@ -38,6 +38,8 @@ src_unpack() {
for i in ${S}/src/Makefile.{in,am} ; do
sed -i.orig -e '/^libgpsim_la_LDFLAGS/s,$, -lpthread,g' $i
done
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
}
src_compile() {