summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pg_top/ChangeLog6
-rw-r--r--dev-db/pg_top/files/pg_top-3.6.2.patch24
-rw-r--r--dev-db/pg_top/pg_top-3.6.2.ebuild12
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-db/pg_top/ChangeLog b/dev-db/pg_top/ChangeLog
index af84e74f0122..bd25a2ce0f55 100644
--- a/dev-db/pg_top/ChangeLog
+++ b/dev-db/pg_top/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/pg_top
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/ChangeLog,v 1.2 2008/06/17 15:27:20 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/ChangeLog,v 1.3 2008/12/21 13:52:06 cedk Exp $
+
+ 21 Dec 2008; Cédric Krier <cedk@gentoo.org> +files/pg_top-3.6.2.patch,
+ pg_top-3.6.2.ebuild:
+ Fix build with --as-needed for bug #247007
17 Jun 2008; Cédric Krier <cedk@gentoo.org> pg_top-3.6.2.ebuild:
Add ~amd64 keyword for bug #227817
diff --git a/dev-db/pg_top/files/pg_top-3.6.2.patch b/dev-db/pg_top/files/pg_top-3.6.2.patch
new file mode 100644
index 000000000000..0d4e82fe26a6
--- /dev/null
+++ b/dev-db/pg_top/files/pg_top-3.6.2.patch
@@ -0,0 +1,24 @@
+diff -ru pg_top-3.6.2~/configure.ac pg_top-3.6.2/configure.ac
+--- pg_top-3.6.2~/configure.ac 2008-12-21 14:43:47.000000000 +0100
++++ pg_top-3.6.2/configure.ac 2008-12-21 14:44:21.000000000 +0100
+@@ -90,7 +90,7 @@
+
+ DBCFLAGS="-I$INCLUDEDIR"
+ LIBDIR=`$PG_CONFIG --libdir`
+-DBLDFLAGS="-L$LIBDIR -lpq"
++DBLDFLAGS="-L$LIBDIR"
+
+ AC_SUBST(DBCFLAGS)
+ AC_SUBST(DBLDFLAGS)
+@@ -109,6 +109,8 @@
+ AC_SEARCH_LIBS(inet_aton, resolv, AC_DEFINE(HAVE_INET_ATON, 1,
+ [inet_aton is already defined]))
+
++AC_SEARCH_LIBS(PQexec, pq)
++
+ # check for libraries required by extension
+ extlibs=""
+ if test -n "$with_ext" -a -f "${srcdir}/ext/$with_ext.libs"; then
+Only in pg_top-3.6.2~: .configure.ac.swp
+Only in pg_top-3.6.2~: .configure.swp
+Only in pg_top-3.6.2~: .Makefile.am.swp
diff --git a/dev-db/pg_top/pg_top-3.6.2.ebuild b/dev-db/pg_top/pg_top-3.6.2.ebuild
index f429f14efb7e..cc615a4b08cf 100644
--- a/dev-db/pg_top/pg_top-3.6.2.ebuild
+++ b/dev-db/pg_top/pg_top-3.6.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/pg_top-3.6.2.ebuild,v 1.2 2008/06/17 15:27:20 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/pg_top-3.6.2.ebuild,v 1.3 2008/12/21 13:52:06 cedk Exp $
+
+inherit eutils
DESCRIPTION="'top' for PostgreSQL"
HOMEPAGE="http://ptop.projects.postgresql.org/"
@@ -16,6 +18,14 @@ DEPEND="$COMMON_DEPEND
dev-util/pkgconfig"
RDEPEND="$COMMON_DEPEND"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}.patch"
+ eautoreconf
+}
+
src_compile() {
econf $(use_enable debug)
emake || die "emake failed"