summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog7
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index 589a15ec6589..174f4a557558 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.98 2011/01/17 16:54:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.99 2011/02/11 16:34:13 pacho Exp $
+
+*libxmlpp-2.33.2 (11 Feb 2011)
+
+ 11 Feb 2011; Pacho Ramos <pacho@gentoo.org> +libxmlpp-2.33.2.ebuild:
+ Version bump for 2.33 series fixing memory management problems and others.
*libxmlpp-2.33.1 (17 Jan 2011)
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild
new file mode 100644
index 000000000000..a6e71841a47a
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild,v 1.1 2011/02/11 16:34:13 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # don't waste time building the examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${ED}"usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}