summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/muParser/ChangeLog8
-rw-r--r--dev-cpp/muParser/files/muParser-1.32-build.patch13
-rw-r--r--dev-cpp/muParser/muParser-1.32.ebuild51
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index 9465c72ab713..e827ddb1c2a5 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/muParser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.12 2010/01/01 17:17:32 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.13 2010/02/14 20:45:26 pva Exp $
+
+*muParser-1.32 (14 Feb 2010)
+
+ 14 Feb 2010; Peter Volkov <pva@gentoo.org> +muParser-1.32.ebuild,
+ +files/muParser-1.32-build.patch:
+ Version bump for qtiplot.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> muParser-1.30.ebuild:
Port Prefix keywords
diff --git a/dev-cpp/muParser/files/muParser-1.32-build.patch b/dev-cpp/muParser/files/muParser-1.32-build.patch
new file mode 100644
index 000000000000..84875e0a1a51
--- /dev/null
+++ b/dev-cpp/muParser/files/muParser-1.32-build.patch
@@ -0,0 +1,13 @@
+--- configure 2008-06-09 22:51:39.000000000 +0100
++++ configure 2009-03-09 16:12:02.335504093 +0000
+@@ -1927,10 +1927,6 @@
+ NONENONEs,x,x, &&
+ program_prefix=${target_alias}-
+
+-CFLAGS=
+-CXXFLAGS=
+-CPPFLAGS=
+-
+ for ac_prog in gawk mawk nawk awk
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
diff --git a/dev-cpp/muParser/muParser-1.32.ebuild b/dev-cpp/muParser/muParser-1.32.ebuild
new file mode 100644
index 000000000000..bdf176ddec58
--- /dev/null
+++ b/dev-cpp/muParser/muParser-1.32.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.32.ebuild,v 1.1 2010/02/14 20:45:26 pva Exp $
+
+EAPI=2
+inherit eutils
+
+MY_PN=${PN/P/p}
+MY_P=${MY_PN}_v${PV/./}
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # fix destdir and respect cxxflags
+ # cant really use autotools cause muparser use bakefile
+ # and too lasy to make an ebuild for it.
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ econf $(use_enable test samples)
+}
+
+src_test() {
+ cat > test.sh <<-EOFTEST
+ LD_LIBRARY_PATH=${S}/lib samples/example1/example1 << EOF
+ quit
+ EOF
+ EOFTEST
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changes.txt Credits.txt || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/html || die
+ fi
+}