summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog9
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.1.ebuild47
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild66
-rw-r--r--dev-cpp/commoncpp2/files/1.5.7-as-needed.patch35
-rw-r--r--dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch29
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.13
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.73
7 files changed, 141 insertions, 51 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 7edb412bdf8d..96576be11ca1 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.29 2007/02/22 00:59:22 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.30 2007/06/16 14:02:24 dev-zero Exp $
+
+*commoncpp2-1.5.7 (16 Jun 2007)
+
+ 16 Jun 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.5.7-as-needed.patch, +files/1.5.7-ssl_config.patch,
+ -commoncpp2-1.5.1.ebuild, +commoncpp2-1.5.7.ebuild:
+ Version bump (fixes bug #179520)
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.1.ebuild
deleted file mode 100644
index 463648f30479..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.5.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.1.ebuild,v 1.1 2006/10/21 20:52:02 genstef Exp $
-
-inherit eutils
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://sourceforge/gnutelephony/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc ipv6"
-
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- dev-libs/libgcrypt
- net-libs/gnutls"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/ccext2-as-needed.diff
-}
-
-src_compile() {
- use doc \
- || sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure
- econf \
- $(use_with ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README \
- THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-}
-
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild
new file mode 100644
index 000000000000..0a164087aca8
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild,v 1.1 2007/06/16 14:02:24 dev-zero Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples ipv6 gnutls"
+
+RDEPEND="gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ sys-libs/zlib"
+DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-as-needed.patch"
+ epatch "${FILESDIR}/${PV}-ssl_config.patch"
+ AT_M4DIR="m4"
+ eautoreconf
+}
+
+src_compile() {
+ use doc || \
+ sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
+
+ local myconf
+ use gnutls || myconf="--with-openssl"
+
+ econf \
+ $(use_enable debug) \
+ $(use_with ipv6 ) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ cd demo
+ doins *.cpp *.h *.xml README
+ fi
+}
+
+# Don't work...
+#src_test() {
+# cd "${S}/tests"
+# emake || die "emake tests failed"
+# ./test.sh || die "tests failed"
+#}
diff --git a/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch b/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch
new file mode 100644
index 000000000000..a1d20c610198
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch
@@ -0,0 +1,35 @@
+diff -Naur commoncpp2-1.5.7.orig/configure.ac commoncpp2-1.5.7/configure.ac
+--- commoncpp2-1.5.7.orig/configure.ac 2007-06-16 15:23:05.000000000 +0200
++++ commoncpp2-1.5.7/configure.ac 2007-06-16 15:24:39.000000000 +0200
+@@ -357,6 +357,9 @@
+ darwin*)
+ MODULE_FLAGS="-dynamic -bundle -undefined suppress -flat_namespace -read_only_relocs suppress"
+ ;;
++linux*)
++ BASE_LIB="../src/libccgnu2.la"
++ ;;
+ esac
+
+ AC_SUBST(COMMON_FLAGS)
+diff -Naur commoncpp2-1.5.7.orig/src/Makefile.am commoncpp2-1.5.7/src/Makefile.am
+--- commoncpp2-1.5.7.orig/src/Makefile.am 2007-06-16 15:23:05.000000000 +0200
++++ commoncpp2-1.5.7/src/Makefile.am 2007-06-16 15:23:32.000000000 +0200
+@@ -32,7 +32,7 @@
+ scriptdir = $(bindir)
+ script_DATA = ccgnu2-config
+
+-libccgnu2_la_LIBADD = @THREAD_LIBS@
++libccgnu2_la_LIBADD = @THREAD_LIBS@ @DYN_LOADER@
+ libccgnu2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
+ noinst_DATA = @STAGE2@
+
+@@ -45,7 +45,8 @@
+ cidr.cpp private.h nat.h
+
+ if EXTRAS
+-libccext2_la_LDFLAGS = @BASE_LIB@ @THREAD_LIBS@ @SSL_LIBS@ @ZSTREAM_LIBS@ $(RELEASE) $(SHARED_FLAGS)
++libccext2_la_LIBADD = @THREAD_LIBS@ @BASE_LIB@ @SSL_LIBS@ @ZSTREAM_LIBS@
++libccext2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
+
+ if GETOPT_LONG
+ optincludedir=$(includedir)/cc++2
diff --git a/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch b/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch
new file mode 100644
index 000000000000..675e99960721
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch
@@ -0,0 +1,29 @@
+--- configure.ac.orig 2006-10-22 18:02:57.000000000 +0200
++++ configure.ac 2006-10-22 18:06:17.000000000 +0200
+@@ -247,6 +247,7 @@
+ ost_cv_extras=yes
+ AC_DEFINE(HAVE_EXTRAS, [1], [Enable extras])
+
++ AC_ARG_WITH(gnutls, [ --with-gnutls Enable gnutls support], [
+ AC_CHECK_HEADER(gnutls/gnutls.h,[
+ AC_CHECK_LIB(gnutls, gnutls_init, [
+ SSL_LIBS="-lgnutls -lgcrypt"
+@@ -254,13 +255,12 @@
+ AC_DEFINE(CCXX_SSL, [GNUTLS], [defines ssl])
+ AC_DEFINE(CCXX_GNUTLS, [1], [define gnutls])
+ ])
+-
+- ],[
+- AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
+- [OST_LIB_SSL],
+- [OST_LIB_NOSSL])
++ ],[])
++ ], [
++ AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
++ [OST_LIB_SSL],
++ [OST_LIB_NOSSL])
+ ])
+-
+ AC_ARG_WITH(compression, [ --without-compression Disable libz compression],
+ [OST_LIB_NOZLIB],
+ [OST_LIB_ZLIB])
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1
deleted file mode 100644
index d9c6b02e1e54..000000000000
--- a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f2b1f011029de128496c33424f145864 commoncpp2-1.5.1.tar.gz 862555
-RMD160 ebfc941ea65bbf10f8d6485945748066280719b9 commoncpp2-1.5.1.tar.gz 862555
-SHA256 32e37df5f089c63d95a150b465d925ea33609c1fe3de952efbdca91add8c45d0 commoncpp2-1.5.1.tar.gz 862555
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.7 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.7
new file mode 100644
index 000000000000..e4388dad2c83
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.7
@@ -0,0 +1,3 @@
+MD5 bd85e157e1f4f457e9137c59d40a13fb commoncpp2-1.5.7.tar.gz 858598
+RMD160 897076e80a9d6acca1c7f11dd1dc94c3a32fc73b commoncpp2-1.5.7.tar.gz 858598
+SHA256 95b0e86c27db1ec0b79abe4097f4449f1e15dde1870202ead0551c506269a504 commoncpp2-1.5.7.tar.gz 858598