summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gocr/ChangeLog10
-rw-r--r--app-text/gocr/files/digest-gocr-0.453
-rw-r--r--app-text/gocr/files/gocr-0.45-makefile.patch22
-rw-r--r--app-text/gocr/gocr-0.45.ebuild50
4 files changed, 83 insertions, 2 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index a25bec244e0f..a3ce68ec11f9 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/gocr
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.47 2007/09/20 20:00:28 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.48 2008/01/26 17:02:46 aballier Exp $
+
+*gocr-0.45 (26 Jan 2008)
+
+ 26 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/gocr-0.45-makefile.patch, +gocr-0.45.ebuild:
+ version bump
20 Sep 2007; Alexis Ballier <aballier@gentoo.org> gocr-0.44.ebuild:
add dep on ghostscript when building doc, bug #188569
diff --git a/app-text/gocr/files/digest-gocr-0.45 b/app-text/gocr/files/digest-gocr-0.45
new file mode 100644
index 000000000000..95038ca0e7a8
--- /dev/null
+++ b/app-text/gocr/files/digest-gocr-0.45
@@ -0,0 +1,3 @@
+MD5 134d459f64656b201ca66eebafa108f0 gocr-0.45.tar.gz 362952
+RMD160 e0c2980fb39ca7c66cdc3e0805480f495fdb1a9b gocr-0.45.tar.gz 362952
+SHA256 d1846fe037b5d509373c92c0bc7dd4e6e5c290962e30e03fea5766326ec4b7f4 gocr-0.45.tar.gz 362952
diff --git a/app-text/gocr/files/gocr-0.45-makefile.patch b/app-text/gocr/files/gocr-0.45-makefile.patch
new file mode 100644
index 000000000000..b2166140f5d3
--- /dev/null
+++ b/app-text/gocr/files/gocr-0.45-makefile.patch
@@ -0,0 +1,22 @@
+diff -Nru gocr-0.44.orig/src/Makefile.in gocr-0.44/src/Makefile.in
+--- gocr-0.44.orig/src/Makefile.in 2006-12-13 17:00:05.000000000 +0100
++++ gocr-0.44/src/Makefile.in 2007-03-29 15:55:06.000000000 +0200
+@@ -45,7 +45,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ # to see the config.h
+ CFLAGS=@CFLAGS@ $(CPPFLAGS) -I../include $(DEFS)
+-LDFLAGS=@LDFLAGS@ @LIBS@ -L.
++LDFLAGS=@LDFLAGS@
++LIBADD=@LIBS@
+ DESTDIR=@prefix@
+
+ .c.o: $(INCLUDEFILES)
+@@ -57,7 +58,7 @@
+
+ $(PROGRAM): $(LIBPGMASCLIB) gocr.o
+ # make it conform to ld --as-needed
+- $(CC) -o $@ gocr.o ./lib$(PGMASCLIB).a $(LDFLAGS)
++ $(CC) $(LDFLAGS) gocr.o ./lib$(PGMASCLIB).a $(LIBADD) -o $@
+ if test -r $(PROGRAM); then cp $@ ../bin; fi
+
+ gocr.o: gocr.h Makefile
diff --git a/app-text/gocr/gocr-0.45.ebuild b/app-text/gocr/gocr-0.45.ebuild
new file mode 100644
index 000000000000..8b6e6c119513
--- /dev/null
+++ b/app-text/gocr/gocr-0.45.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.45.ebuild,v 1.1 2008/01/26 17:02:46 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE="doc tk"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 virtual/ghostscript )
+ tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ econf || die "econf failed"
+ emake ${mymakes} || die "make ${mymakes} failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" exec_prefix="/usr" install || die "make install failed"
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${D}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+ insinto /usr/share/doc/${P}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ fi
+ # and then install all the docs
+ dodoc ${DOCS}
+}