summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/openjade')
-rw-r--r--app-text/openjade/ChangeLog7
-rw-r--r--app-text/openjade/files/openjade-1.3.2-gcc46.patch74
-rw-r--r--app-text/openjade/openjade-1.3.2-r3.ebuild10
3 files changed, 88 insertions, 3 deletions
diff --git a/app-text/openjade/ChangeLog b/app-text/openjade/ChangeLog
index 71b07ad52158..7d6c50d80616 100644
--- a/app-text/openjade/ChangeLog
+++ b/app-text/openjade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/openjade
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.63 2011/01/12 12:17:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.64 2011/05/14 14:51:25 angelos Exp $
+
+ 14 May 2011; Christoph Mende <angelos@gentoo.org> openjade-1.3.2-r3.ebuild,
+ +files/openjade-1.3.2-gcc46.patch:
+ Fix compilation with gcc-4.6, thanks to Ryan Hill and Jean-Francis Roy (bug
+ #358021)
12 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-openjade-1.3.2-r1.ebuild, -openjade-1.3.2-r2.ebuild,
diff --git a/app-text/openjade/files/openjade-1.3.2-gcc46.patch b/app-text/openjade/files/openjade-1.3.2-gcc46.patch
new file mode 100644
index 000000000000..e947ffe12f7f
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-gcc46.patch
@@ -0,0 +1,74 @@
+--- openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:08:49.274006803 +0000
++++ openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:14:09.849006939 +0000
+@@ -88,6 +88,8 @@
+ value.convertString(nic_.placement);
+ }
+ ExtensionFlowObj *copy() const { return new PageFloatFlowObj(*this); }
++ public:
++ PageFloatFlowObj() {}
+ private:
+ PageFloatNIC nic_;
+ StringC name_;
+@@ -101,6 +103,8 @@
+ fotb.endPageFootnote();
+ }
+ ExtensionFlowObj *copy() const { return new PageFootnoteFlowObj(*this); }
++ public:
++ PageFootnoteFlowObj() {}
+ private:
+ };
+ //////////////////////////////////////////////////////////////////////
+--- openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:08:49.275006803 +0000
++++ openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:18:31.614007052 +0000
+@@ -41,6 +41,7 @@
+ };
+ class EntityRefFlowObj : public TransformExtensionFlowObj {
+ public:
++ EntityRefFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.entityRef(name_);
+ }
+@@ -56,6 +57,7 @@
+ };
+ class ProcessingInstructionFlowObj : public TransformExtensionFlowObj {
+ public:
++ ProcessingInstructionFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.processingInstruction(data_);
+ }
+@@ -98,6 +100,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new EmptyElementFlowObj(*this); }
++ public:
++ EmptyElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -133,6 +137,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new ElementFlowObj(*this); }
++ public:
++ ElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -150,6 +156,8 @@
+ value.convertString(systemId_);
+ }
+ ExtensionFlowObj *copy() const { return new EntityFlowObj(*this); }
++ public:
++ EntityFlowObj() {};
+ private:
+ StringC systemId_;
+ };
+@@ -174,6 +182,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new DocumentTypeFlowObj(*this); }
++ public:
++ DocumentTypeFlowObj() {}
+ private:
+ DocumentTypeNIC nic_;
+ };
diff --git a/app-text/openjade/openjade-1.3.2-r3.ebuild b/app-text/openjade/openjade-1.3.2-r3.ebuild
index ca5f0d3dcf6b..15c5a68c769f 100644
--- a/app-text/openjade/openjade-1.3.2-r3.ebuild
+++ b/app-text/openjade/openjade-1.3.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r3.ebuild,v 1.8 2011/01/12 10:35:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r3.ebuild,v 1.9 2011/05/14 14:51:25 angelos Exp $
EAPI=2
@@ -21,7 +21,13 @@ DEPEND="dev-lang/perl
${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{deplibs,ldflags,msggen.pl,respect-ldflags,libosp-la}.patch
+ epatch "${FILESDIR}"/${P}-deplibs.patch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-msggen.pl.patch \
+ "${FILESDIR}"/${P}-respect-ldflags.patch \
+ "${FILESDIR}"/${P}-libosp-la.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+
# Please note! Opts are disabled. If you know what you're doing
# feel free to remove this line. It may cause problems with
# docbook-sgml-utils among other things.