summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ispell')
-rw-r--r--app-text/ispell/ChangeLog8
-rw-r--r--app-text/ispell/files/digest-ispell-3.3.026
-rw-r--r--app-text/ispell/ispell-3.3.02.ebuild66
3 files changed, 79 insertions, 1 deletions
diff --git a/app-text/ispell/ChangeLog b/app-text/ispell/ChangeLog
index cc77ebd850c5..1b2697cb1388 100644
--- a/app-text/ispell/ChangeLog
+++ b/app-text/ispell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ispell
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.31 2007/08/18 13:37:30 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.32 2007/11/21 17:21:03 philantrop Exp $
+
+*ispell-3.3.02 (21 Nov 2007)
+
+ 21 Nov 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +ispell-3.3.02.ebuild:
+ Version bump as per bug 97881.
18 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+files/ispell-3.2.06-stripping.diff, ispell-3.2.06-r6.ebuild:
diff --git a/app-text/ispell/files/digest-ispell-3.3.02 b/app-text/ispell/files/digest-ispell-3.3.02
new file mode 100644
index 000000000000..d2d2094f2aa9
--- /dev/null
+++ b/app-text/ispell/files/digest-ispell-3.3.02
@@ -0,0 +1,6 @@
+MD5 8c1b1e0a920a22437c86428d4a0982ba ispell-3.3.02-gentoo-0.2.diff.bz2 5723
+RMD160 6c76be7b90ae65196c9ef5dcd89406e03705374c ispell-3.3.02-gentoo-0.2.diff.bz2 5723
+SHA256 22f50af967290f46bf357bc54ad9fa7de433868632a65e8fc5b148e1a55ec218 ispell-3.3.02-gentoo-0.2.diff.bz2 5723
+MD5 12087d7555fc2b746425cd167af480fe ispell-3.3.02.tar.gz 619813
+RMD160 12edc94ebb7c1f4040bd8f5b0dbb8f40326aa781 ispell-3.3.02.tar.gz 619813
+SHA256 7ff5aad2722ad80fa86766218b7bc622b25bad2d765ea942ba93c996b113ecb4 ispell-3.3.02.tar.gz 619813
diff --git a/app-text/ispell/ispell-3.3.02.ebuild b/app-text/ispell/ispell-3.3.02.ebuild
new file mode 100644
index 000000000000..402814a58f25
--- /dev/null
+++ b/app-text/ispell/ispell-3.3.02.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02.ebuild,v 1.1 2007/11/21 17:21:03 philantrop Exp $
+
+inherit eutils multilib
+
+PATCH_VER="0.2"
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.diff.bz2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/miscfiles
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-gentoo-${PATCH_VER}.diff"
+
+ sed -i -e "s:GENTOO_LIBDIR:$(get_libdir):" local.h.gentoo || die "setting libdir failed"
+ cp local.h.gentoo local.h
+}
+
+src_compile() {
+ emake config.sh || die
+
+ # Fix config.sh to install to ${D}
+ cp -p config.sh config.sh.orig
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN45DIR='\)\(.*\):\1${D}\2:" \
+ < config.sh > config.sh.install
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ cp -p config.sh.install config.sh
+
+ # Need to create the directories to install into
+ # before 'make install'. Build environment **doesn't**
+ # check for existence and create if not already there.
+ dodir /usr/bin /usr/$(get_libdir)/ispell /usr/share/info \
+ /usr/share/man/man1 /usr/share/man/man5
+
+ emake install || die "Installation Failed"
+
+ rmdir "${D}"/usr/share/info || die "removing empty info dir failed"
+ dodoc CHANGES Contributors README WISHES || die "installing docs failed"
+ dosed "${D}"/usr/share/man/man1/ispell.1 || die "dosed failed"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "If you just updated from an older version of ${PN} you *have* to re-emerge"
+ ewarn "all your dictionaries to avoid segmentation faults and other problems."
+ echo
+}