summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-20020624.ebuild10
-rw-r--r--app-shells/bash-completion/bash-completion-20020727.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20020812.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20020819.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021007.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021013.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021017.ebuild6
-rw-r--r--app-shells/psh/psh-0.009-r1.ebuild10
-rw-r--r--app-shells/sash/sash-3.4-r3.ebuild4
-rw-r--r--app-shells/sash/sash-3.4-r4.ebuild12
-rw-r--r--app-shells/sash/sash-3.4-r5.ebuild11
-rw-r--r--app-shells/scsh/scsh-0.6.1-r1.ebuild4
-rw-r--r--app-shells/tcsh/tcsh-6.10-r3.ebuild23
13 files changed, 46 insertions, 64 deletions
diff --git a/app-shells/bash-completion/bash-completion-20020624.ebuild b/app-shells/bash-completion/bash-completion-20020624.ebuild
index 86336b3ec076..f776006dceba 100644
--- a/app-shells/bash-completion/bash-completion-20020624.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020624.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020624.ebuild,v 1.10 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020624.ebuild,v 1.11 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,11 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
-
+src_install() {
insinto /etc
doins bash_completion
@@ -35,15 +34,12 @@ src_install () {
doins ${FILESDIR}/bash-completion
dodoc COPYING Changelog README
-
}
pkg_postinst() {
-
echo
einfo "Add the following line to your ~/.bashrc to"
einfo "activate completion support in your bash:"
einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
echo
-
}
diff --git a/app-shells/bash-completion/bash-completion-20020727.ebuild b/app-shells/bash-completion/bash-completion-20020727.ebuild
index 0eedd73cfd63..8b2d72a1a2e2 100644
--- a/app-shells/bash-completion/bash-completion-20020727.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020727.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020727.ebuild,v 1.4 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020727.ebuild,v 1.5 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20020812.ebuild b/app-shells/bash-completion/bash-completion-20020812.ebuild
index a24eec8aaab5..703e226026d8 100644
--- a/app-shells/bash-completion/bash-completion-20020812.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020812.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020812.ebuild,v 1.4 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020812.ebuild,v 1.5 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20020819.ebuild b/app-shells/bash-completion/bash-completion-20020819.ebuild
index 20c19c4a1c9e..c5ae6d605f89 100644
--- a/app-shells/bash-completion/bash-completion-20020819.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020819.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020819.ebuild,v 1.2 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020819.ebuild,v 1.3 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021007.ebuild b/app-shells/bash-completion/bash-completion-20021007.ebuild
index cf7a5e1cfe5e..b37be4a3de9d 100644
--- a/app-shells/bash-completion/bash-completion-20021007.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021007.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021007.ebuild,v 1.1 2002/10/12 10:02:18 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021007.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021013.ebuild b/app-shells/bash-completion/bash-completion-20021013.ebuild
index 126d4bfe6dc9..48bd815f3e95 100644
--- a/app-shells/bash-completion/bash-completion-20021013.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021013.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021013.ebuild,v 1.1 2002/10/14 21:12:47 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021013.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021017.ebuild b/app-shells/bash-completion/bash-completion-20021017.ebuild
index 0f1bc2949b06..d4a608a57d42 100644
--- a/app-shells/bash-completion/bash-completion-20021017.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021017.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.1 2002/10/17 13:49:18 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/psh/psh-0.009-r1.ebuild b/app-shells/psh/psh-0.009-r1.ebuild
index c075ff4fffa4..8f979c15367e 100644
--- a/app-shells/psh/psh-0.009-r1.ebuild
+++ b/app-shells/psh/psh-0.009-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.7 2002/10/04 05:02:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
@@ -19,10 +19,10 @@ src_compile() {
}
src_install() {
- make PREFIX=${D}/usr \
- prefix=${D}/usr \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- install || die
+ make PREFIX=${D}/usr \
+ prefix=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
dodoc COPYRIGHT HACKING MANIFEST README* RELEASE TODO
dodoc examples/complete-examples
diff --git a/app-shells/sash/sash-3.4-r3.ebuild b/app-shells/sash/sash-3.4-r3.ebuild
index ebf29d8728cb..869f54fd3233 100644
--- a/app-shells/sash/sash-3.4-r3.ebuild
+++ b/app-shells/sash/sash-3.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.12 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.13 2002/10/17 14:31:29 vapier Exp $
IUSE="readline static"
@@ -18,7 +18,7 @@ fi
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
KEYWORDS="x86 ppc sparc sparc64"
diff --git a/app-shells/sash/sash-3.4-r4.ebuild b/app-shells/sash/sash-3.4-r4.ebuild
index 0ac6b1ee810b..f59f68cab335 100644
--- a/app-shells/sash/sash-3.4-r4.ebuild
+++ b/app-shells/sash/sash-3.4-r4.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r4.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r4.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
IUSE="readline"
S=${WORKDIR}/${P}
DESCRIPTION="A small static UNIX Shell with readline suppport"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
- http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
@@ -18,6 +18,7 @@ DEPEND="virtual/glibc
RDEPEND=""
KEYWORDS="x86 ppc sparc sparc64"
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -35,18 +36,13 @@ src_unpack() {
}
src_compile() {
-
make || die
-
}
src_install() {
-
into /
dobin sash
into /usr
doman sash.1
dodoc README
-
}
-
diff --git a/app-shells/sash/sash-3.4-r5.ebuild b/app-shells/sash/sash-3.4-r5.ebuild
index 145e80bd134a..910016088ca9 100644
--- a/app-shells/sash/sash-3.4-r5.ebuild
+++ b/app-shells/sash/sash-3.4-r5.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.9 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.10 2002/10/17 14:31:29 vapier Exp $
IUSE="readline"
S=${WORKDIR}/${P}
DESCRIPTION="A small static UNIX Shell with readline support"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
- http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.4
@@ -36,18 +36,13 @@ src_unpack() {
}
src_compile() {
-
make || die
-
}
src_install() {
-
into /
dobin sash
into /usr
doman sash.1
dodoc README
-
}
-
diff --git a/app-shells/scsh/scsh-0.6.1-r1.ebuild b/app-shells/scsh/scsh-0.6.1-r1.ebuild
index c8779f7981d1..7a5fb299f6b3 100644
--- a/app-shells/scsh/scsh-0.6.1-r1.ebuild
+++ b/app-shells/scsh/scsh-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1-r1.ebuild,v 1.7 2002/10/04 05:02:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1-r1.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Scsh is a Unix shell embedded in Scheme"
@@ -8,7 +8,7 @@ SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/${P}.tar.gz"
HOMEPAGE="http://www.scsh.net/"
SLOT="0"
-LICENSE="as-is | BSD | GPL"
+LICENSE="as-is | BSD | GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
DEPEND="virtual/glibc"
diff --git a/app-shells/tcsh/tcsh-6.10-r3.ebuild b/app-shells/tcsh/tcsh-6.10-r3.ebuild
index bf168d71a823..1e6099aa79ab 100644
--- a/app-shells/tcsh/tcsh-6.10-r3.ebuild
+++ b/app-shells/tcsh/tcsh-6.10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
IUSE="perl"
@@ -12,20 +12,19 @@ SRC_URI="ftp://ftp.gw.com/pub/unix/tcsh/${P}.tar.gz
HOMEPAGE="http://www.tcsh.org/"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.1
- perl? ( sys-devel/perl )"
+ perl? ( sys-devel/perl )"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="BSD"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
}
src_compile() {
-
./configure \
--prefix=/ \
--mandir=/usr/share/man \
@@ -38,17 +37,13 @@ src_compile() {
src_install() {
make DESTDIR=${D} install install.man || die
- if [ "`use perl`" ]
- then
- perl tcsh.man2html || die
- dohtml tcsh.html/*.html
- fi
+ if [ "`use perl`" ]; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
dosym tcsh /bin/csh
dodoc FAQ Fixes NewThings Ported README WishList Y2K
insinto /etc
doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
}
-
-
-