summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-3.0-r12.ebuild')
-rw-r--r--app-shells/bash/bash-3.0-r12.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/app-shells/bash/bash-3.0-r12.ebuild b/app-shells/bash/bash-3.0-r12.ebuild
index e94f236b5fe1..761c75d90ac9 100644
--- a/app-shells/bash/bash-3.0-r12.ebuild
+++ b/app-shells/bash/bash-3.0-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r12.ebuild,v 1.7 2006/03/08 01:21:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r12.ebuild,v 1.8 2006/03/23 23:07:21 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -91,8 +91,6 @@ src_unpack() {
# side - although reproduceble with later 2.4 kernels, it is
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
src_compile() {
@@ -113,20 +111,14 @@ src_compile() {
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf="${myconf} --disable-nls"
- echo 'int main(){}' > "${T}"/term-test.c
- if ! $(tc-getCC) -static -lncurses "${T}"/term-test.c 2> /dev/null ; then
- export bash_cv_termcap_lib=gnutermcap
- else
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-curses"
- fi
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ myconf="${myconf} --with-curses"
econf \
--disable-profiling \
--without-gnu-malloc \
${myconf} || die
- # Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake -j1 || die "make failed" # see bug 102426
}