summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/ChangeLog8
-rw-r--r--app-office/openoffice-bin/files/1.1.5/ooffice-wrapper-1.3197
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.1.51
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild167
4 files changed, 372 insertions, 1 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 6fc9f224b2a4..7b213854aa05 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.90 2005/09/14 05:39:06 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.91 2005/09/14 17:32:02 suka Exp $
+
+*openoffice-bin-1.1.5 (14 Sep 2005)
+
+ 14 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/1.1.5/ooffice-wrapper-1.3, +openoffice-bin-1.1.5.ebuild:
+ Version bump
14 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
openoffice-bin-1.9.128.ebuild:
diff --git a/app-office/openoffice-bin/files/1.1.5/ooffice-wrapper-1.3 b/app-office/openoffice-bin/files/1.1.5/ooffice-wrapper-1.3
new file mode 100644
index 000000000000..78b242ca2c9a
--- /dev/null
+++ b/app-office/openoffice-bin/files/1.1.5/ooffice-wrapper-1.3
@@ -0,0 +1,197 @@
+#!/bin/sh
+#
+# Wrapper script for openoffice
+#
+# (C) Peter 'Nidd' Novodvorsky, 2001,2002
+# (C) Martin 'empty' Quinson, 2002.
+# Modifications by Chris Halls
+# Modifications by Lucien Saviot
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+# this string should be exactly as in ~/.sversionrc
+PV=<pv>
+OOVERSION="OpenOffice.org ${PV}"
+
+##
+## Source system configuration file
+##
+[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
+
+# Migration to new user install dir
+if [ -d "$HOME/.openoffice/1.1.4" ] ; then
+ mv $HOME/.openoffice/1.1.4 $HOME/.openoffice/1.1.5
+ sed -i -e s/'.openoffice\/1.1.4'/'.openoffice\/1.1.5'/g $HOME/.sversionrc
+ sed -i -e s/1.1.4/1.1.5/g $HOME/.openoffice/1.1.5/user/basic/*.xlc
+ echo "Your user install dir has been moved over to the new version"
+fi
+
+#Make smooth up- and downgrading between minor versions possible
+if [ -e "$HOME/.sversionrc" ] ; then
+ sed -i -e s/1.1.4/1.1.5/g $HOME/.sversionrc
+fi
+
+if [ ! -f "/proc/version" ] ; then
+ echo "--- Warning - OO.o will not work without a mounted /proc filesystem ---"
+fi
+
+###
+### Get user settings directory from ~/.sversionrc and echo directory name to stdout
+### get_settings_dir <Version>
+### return: 0 - directory found,
+### 1 - ~/.sversionrc non existent
+### 2 - entry exists in ~/.sversionrc but directory not found
+### 3 - ~/.sversionrc exists but no entry found
+get_settings_dir()
+{
+ [ -r ${HOME}/.sversionrc ] || exit 1
+ # warning, .sversionrc is DOS encoded so strip ^M
+ settings_dir="`tr -d '\r' < ~/.sversionrc | sed -n "/^$1=/s%^$1=file://\(.*\)$%\1%p"`"
+ echo "$settings_dir"
+ [ -n "$settings_dir" ] || exit 3
+ [ -d "$settings_dir" ] || exit 2
+}
+
+##
+## where does OO live for this user ?
+##
+OOHOME="`get_settings_dir "$OOVERSION"`"
+if [ $? -eq 2 ] ; then
+ # .sversionrc contains a version yet the directory does not exist
+ echo "I'm confused because I can't find OpenOffice's user files."
+ echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
+ echo "but they are not. Please fix the situation manually."
+ echo "You may want to edit ~/.sversionrc to indicate where is OO"
+ echo "installed, or remove it if you did remove your installation"
+ echo "directory manually (you bad one)."
+ exit 1
+fi
+
+##
+## Add /usr/share/fonts to font search path
+##
+
+# Default font path. This is used if SAL_FONTPATH_PRIVATE is not defined.
+
+GENTOO_FONTPATH=""
+for d in `find /usr/share/fonts -maxdepth 1 -mindepth 1 -type d` ; do
+ GENTOO_FONTPATH="$GENTOO_FONTPATH;$d"
+done
+
+SAL_FONTPATH_PRIVATE=${SAL_FONTPATH_PRIVATE:-"$GENTOO_FONTPATH"}
+export SAL_FONTPATH_PRIVATE
+
+## search LOCALE
+if [ -n "$LC_ALL" ]; then
+ LOCALE="$LC_ALL"
+ # OOo doesn't understand LC_ALL, so set LANG
+ LANG="$LC_ALL"
+elif [ -n "$LANG" ]; then
+ LOCALE="$LANG"
+elif [ -n "$LC_MESSAGES" ]; then
+ LOCALE="$LC_MESSAGES"
+ LANG="$LC_MESSAGES"
+else
+ LOCALE="en_US"
+fi
+
+# Set locale to en_US if locale is C
+if [ "x$LOCALE" = "xC" ] ; then LOCALE="en_US"; fi
+
+LOCALEOO=`echo $LOCALE | sed 's/_/-/'`
+
+##
+## install OO for this user if needed
+##
+if [ -z "$OOHOME" ] ; then
+ if [ -e /etc/openoffice/autoresponse-<pv>.conf ] && \
+ grep -q DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf ; then
+
+ # first install
+ OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf | \
+ sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
+
+ if [ -d "$OOHOME" ]; then
+ echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
+ echo "yet the directory $OOHOME exists."
+ echo "Please remove $OOHOME and try again."
+ exit 1
+ fi
+
+ echo "running openoffice.org setup..."
+ if ! /opt/OpenOffice.org/program/setup -R:/etc/openoffice/autoresponse-<pv>.conf >& /dev/null; then
+ echo "setup failed.. abort"
+ exit 1
+ fi
+
+ echo "Setup complete. Running openoffice.org..."
+
+else
+ echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
+ echo "the /etc/openoffice/autoresponse-<pv>.conf file manually ?"
+ echo "This file should contain DESTINATIONPATH"
+ exit 1
+ fi
+fi
+
+##
+## If no file is specified on the command line, which application to start?
+## The wrapper can be called from several links in /usr/bin
+##
+if [ $# = 0 ]; then
+ case `basename $0` in
+ oocalc) set -- private:factory/scalc;;
+ oodraw) set -- private:factory/sdraw;;
+ ooimpress) set -- private:factory/simpress;;
+ oomath) set -- private:factory/smath;;
+ ooweb) set -- private:factory/swriter/web;;
+ oowriter) set -- private:factory/swriter;;
+ oomaster) set -- private:factory/swriter/Global;;
+ esac
+fi
+
+## Previous dead installation?
+[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
+
+# Check whether the programs actually link to anything, or are from an old
+# version.
+
+if [ ! -s $OOHOME/setup ]; then
+ echo "${OOHOME}/setup links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/setup ${OOHOME}/setup
+fi
+if [ ! -s $OOHOME/soffice ]; then
+ echo "${OOHOME}/soffice links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/soffice
+fi
+if [ ! -s $OOHOME/spadmin ]; then
+ echo "${OOHOME}/spadmin links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/spadmin
+fi
+
+
+##
+## That's it. Launch the beast (with the given args)
+##
+LANG=$LOCALE
+export LANG
+case `basename $0` in
+ oosetup) exec "$OOHOME/setup"
+ ;;
+ oopadmin) exec "$OOHOME/spadmin"
+ ;;
+ *) exec "$OOHOME/soffice" "$@"
+ ;;
+esac
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.5 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.5
new file mode 100644
index 000000000000..cb1270b910f0
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.5
@@ -0,0 +1 @@
+MD5 d533afa5931e722f08df478ef38863db OOo_1.1.5_LinuxIntel_install.tar.gz 80457121
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild
new file mode 100644
index 000000000000..eab3bb17a4d1
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild,v 1.1 2005/09/14 17:32:02 suka Exp $
+
+# NOTE: There are two big issues that should be addressed.
+#
+# 1) Language support and fonts should be addressed.
+
+inherit eutils fdo-mime
+
+IUSE="java kde"
+
+INSTDIR="/opt/OpenOffice.org"
+MY_P="OOo_${PV}_LinuxIntel_install"
+
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="OpenOffice productivity suite"
+
+SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
+ amd64? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )"
+
+HOMEPAGE="http://www.openoffice.org/"
+
+LICENSE="|| ( LGPL-2 SISSL-1.1 )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="!app-office/openoffice
+ virtual/x11
+ virtual/libc
+ >=dev-lang/perl-5.0
+ app-arch/zip
+ app-arch/unzip
+ java? ( >=virtual/jre-1.4.1 )
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
+
+DEPEND="${RDEPEND}
+ sys-apps/findutils"
+
+PROVIDE="virtual/ooo"
+
+src_install() {
+ # Sandbox issues; bug #8587
+ addpredict "/user"
+ addpredict "/share"
+ addpredict "/dev/dri"
+ addpredict "/usr/bin/soffice"
+ addpredict "/pspfontcache"
+ addpredict "/root/.gconfd"
+ addpredict "/opt/OpenOffice.org/foo.tmp"
+ addpredict "/opt/OpenOffice.org/delme"
+
+ # Autoresponse file for main installation
+ cat > ${T}/rsfile-global <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_NETWORK
+ INSTALLATIONTYPE=STANDARD
+ DESTINATIONPATH=<destdir>
+ OUTERPATH=
+ LOGFILE=
+ LANGUAGELIST=<LANGUAGE>
+
+ [JAVA]
+ JavaSupport=preinstalled_or_none
+ END_RS
+
+ # Autoresponse file for user installation
+ cat > ${T}/rsfile-local <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_WORKSTATION
+ INSTALLATIONTYPE=WORKSTATION
+ DESTINATIONPATH=<home>/.openoffice/<pv>
+
+ [JAVA]
+ JavaSupport=none
+ END_RS
+
+ # Fixing install location in response file
+ sed -e "s|<destdir>|${D}${INSTDIR}|" \
+ ${T}/rsfile-global > ${T}/autoresponse || die
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ cd ${S}
+ ./setup -v -noexit -nogui -r:${T}/autoresponse || die "Setup failed"
+
+ einfo "Removing build root from registry..."
+ # Remove totally useless stuff.
+ rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh} || die
+ # Remove build root from registry and co
+ egrep -rl "${D}" ${D}${INSTDIR}/* | \
+ xargs -i perl -pi -e "s|${D}||g" {} || :
+
+ einfo "Fixing permissions..."
+ # Fix permissions
+ find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
+ chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
+
+ # Install user autoresponse file
+ insinto /etc/openoffice
+ sed -e "s|<pv>|${PV}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
+ doins ${T}/autoresponse-${PV}.conf
+
+ # Install wrapper script
+ exeinto /usr/bin
+ sed -e "s|<pv>|${PV}|g" \
+ ${FILESDIR}/${PV}/ooffice-wrapper-1.3 > ${T}/ooffice
+ doexe ${T}/ooffice
+
+ # Component symlinks
+ for app in calc draw impress math writer web setup padmin; do
+ dosym ooffice /usr/bin/oo${app}
+ done
+
+ einfo "Installing menu shortcuts..."
+ dodir /usr/share
+ cp -pPR ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
+
+ use kde && cp -pPR ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}/usr/share
+
+ for x in ${D}${INSTDIR}/share/kde/net/*.desktop; do
+ # We have to handle soffice and setup differently
+ sed -i -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ sed -i -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
+ # Now fix the rest
+ sed -i -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ echo "Categories=Application;Office;" >> ${x}
+ domenu ${x}
+ rm ${x}
+ done
+
+ # Remove unneeded stuff
+ rm -rf ${D}${INSTDIR}/share/cde || die
+
+ # Fix instdb.ins, to *not* install local copies of these
+ for entry in Kdeapplnk Kdemimetext Kdeicons Gnome_Apps Gnome_Icons Gnome2_Apps; do
+ perl -pi -e "/^File gid_File_Extra_$entry/ .. /^End/ and (\
+ s|^\tSize\s+\= .*|\tSize\t\t = 0;\r| or \
+ s|^\tArchiveFiles\s+\= .*|\tArchiveFiles\t = 0;\r| or \
+ s|^\tArchiveSize\s+\= .*|\tArchiveSize\t = 0;\r| or \
+ s|^\tContains\s+\= .*|\tContains\t = ();\r| or \
+ s|\t\t\t\t\t\".*|\r|g)" \
+ ${D}${INSTDIR}/program/instdb.ins
+ done
+
+ # Make sure these do not get nuked.
+ keepdir ${INSTDIR}/user/registry/res/en-us/org/openoffice/{Office,ucb} ${INSTDIR}/user/psprint/{driver,fontmetric} ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
+
+ #touch files to make portage uninstalling happy (#22593)
+ find ${D} -type f -exec touch {} \;
+
+}
+
+pkg_postinst() {
+
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oocalc, oodraw, ooimpress, oomath, ooweb or oowriter"
+}
+