summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.203
-rw-r--r--app-mobilephone/wammu/wammu-0.20.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 7feb9f54f585..6f1ace076cac 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.17 2007/03/23 09:45:42 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.18 2007/05/22 06:58:37 mrness Exp $
+
+*wammu-0.20 (22 May 2007)
+
+ 22 May 2007; Alin Năstac <mrness@gentoo.org> +wammu-0.20.ebuild:
+ Version bump.
*wammu-0.19 (23 Mar 2007)
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.20 b/app-mobilephone/wammu/files/digest-wammu-0.20
new file mode 100644
index 000000000000..e8d57c091cf0
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.20
@@ -0,0 +1,3 @@
+MD5 07293f72304e36626525a7efbd871bbb wammu-0.20.tar.bz2 267646
+RMD160 e0d540568f10312720f072944d8b2221bd52b124 wammu-0.20.tar.bz2 267646
+SHA256 9ae38804601f5daeb162a34da7e1bbfc1364df8a37d1cf27a44b884af7c00995 wammu-0.20.tar.bz2 267646
diff --git a/app-mobilephone/wammu/wammu-0.20.ebuild b/app-mobilephone/wammu/wammu-0.20.ebuild
new file mode 100644
index 000000000000..4b52ba8c4c52
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.20.ebuild,v 1.1 2007/05/22 06:58:37 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+#gnome-bluetooth is used for additional functionality - see bug #101067
+RDEPEND=">=dev-python/wxpython-2.6
+ >=dev-python/python-gammu-0.20
+ bluetooth? (
+ net-wireless/gnome-bluetooth
+ dev-python/pybluez
+ )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}