summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/sms/sms-2.0.3.ebuild')
-rw-r--r--app-mobilephone/sms/sms-2.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-mobilephone/sms/sms-2.0.3.ebuild b/app-mobilephone/sms/sms-2.0.3.ebuild
new file mode 100644
index 000000000000..05cbafc187c4
--- /dev/null
+++ b/app-mobilephone/sms/sms-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/sms/sms-2.0.3.ebuild,v 1.1 2005/05/15 19:50:28 mrness Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command line program for sending SMS to Polish GSM mobile phone users"
+HOMEPAGE="http://ceti.pl/~miki/komputery/sms.html"
+SRC_URI="http://ceti.pl/~miki/komputery/download/sms/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+RDEPEND="virtual/libc
+ sys-libs/gdbm
+ dev-libs/libpcre
+ dev-libs/pcre++
+ net-misc/curl"
+
+DEPEND="${RDEPEND}
+ sys-devel/gcc
+ sys-apps/sed"
+
+src_compile() {
+ emake CXX=$(tc-getCXX) CXXFLAGS="${CXXFLAGS} -I./lib" LDFLAGS="-lc" || die
+}
+
+src_install() {
+ dobin sms smsaddr
+ dodoc README README.smsrc Changelog doc/readme.html
+ dodoc contrib/mimecut contrib/procmailrc
+}