summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog8
-rw-r--r--app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild12
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild12
3 files changed, 19 insertions, 13 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index be831e983b3c..94c547bfc965 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.27 2010/03/06 20:17:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.28 2010/03/06 20:23:15 robbat2 Exp $
+
+ 06 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ g15daemon-1.2.7-r1.ebuild, g15daemon-1.9.5.3-r2.ebuild:
+ Bug #300337: the CONFIG_INPUT_UINPUT needs to be safe when no detection of
+ config options is possible. Just display the warning if we cannot in that
+ case. Also be non-fatal if the option can be tested and is not set.
06 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
Changing maintainer per emails of Jan 18th.
diff --git a/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild b/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild
index a728860c8fe7..6e916cc0c98e 100644
--- a/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild,v 1.4 2009/05/16 09:16:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild,v 1.5 2010/03/06 20:23:15 robbat2 Exp $
inherit eutils linux-info perl-module python multilib
@@ -24,10 +24,11 @@ RDEPEND="${DEPEND}
uinput_check() {
ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
- if [[ $? -ne 0 ]] ; then
+ if [[ $rc -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -35,7 +36,6 @@ uinput_check() {
eerror
eerror "Once enabled, you should have the /dev/input/uinput device."
eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
fi
}
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild
index 7a850ae391e2..75c3f89efd2e 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild,v 1.4 2009/05/16 09:16:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild,v 1.5 2010/03/06 20:23:15 robbat2 Exp $
EAPI=2
@@ -27,10 +27,11 @@ RDEPEND="${DEPEND}
PATCHES=( "${FILESDIR}/${P}-forgotten-open-mode.patch" )
uinput_check() {
ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
- if [[ $? -ne 0 ]] ; then
+ if [[ $rc -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -38,7 +39,6 @@ uinput_check() {
eerror
eerror "Once enabled, you should have the /dev/input/uinput device."
eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
fi
}