summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-4.2-r1.ebuild54
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.2-r11
3 files changed, 61 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index e5432105548a..35144bbc7bd6 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.8 2004/12/08 01:35:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.9 2004/12/19 03:27:34 vapier Exp $
+
+*cedega-4.2-r1 (18 Dec 2004)
+
+ 18 Dec 2004; Mike Frysinger <vapier@gentoo.org> +cedega-4.2-r1.ebuild:
+ Version bump #74893 by Erdroh Moshan.
*cedega-4.2 (07 Dec 2004)
diff --git a/app-emulation/cedega/cedega-4.2-r1.ebuild b/app-emulation/cedega/cedega-4.2-r1.ebuild
new file mode 100644
index 000000000000..18b217a8a0c7
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.2-r1.ebuild,v 1.1 2004/12/19 03:27:34 vapier Exp $
+
+MY_P="cedega_${PV}ForSteam-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.2-r1 b/app-emulation/cedega/files/digest-cedega-4.2-r1
new file mode 100644
index 000000000000..e5e71aaba353
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.2-r1
@@ -0,0 +1 @@
+MD5 c978b61e9f198b920da2cc54ff1499ac cedega_4.2ForSteam-1.i386.tgz 7489935