summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gxemul/ChangeLog9
-rw-r--r--app-emulation/gxemul/files/0.6.0-gcc46.patch16
-rw-r--r--app-emulation/gxemul/gxemul-0.4.6.2.ebuild40
-rw-r--r--app-emulation/gxemul/gxemul-0.4.7.ebuild40
-rw-r--r--app-emulation/gxemul/gxemul-0.6.0.ebuild26
5 files changed, 37 insertions, 94 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 5ed1220f6a70..12c82720dc3a 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/gxemul
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.15 2010/09/20 21:00:38 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.16 2011/04/22 12:32:02 jlec Exp $
+
+ 22 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/0.6.0-gcc46.patch,
+ -gxemul-0.4.6.2.ebuild, -gxemul-0.4.7.ebuild, gxemul-0.6.0.ebuild:
+ Cleaned old, disabled valgrind usage #352604, fixes gcc46 problems, #363489;
+ don't install what is not there #315717; added debug USE
*gxemul-0.6.0 (20 Sep 2010)
diff --git a/app-emulation/gxemul/files/0.6.0-gcc46.patch b/app-emulation/gxemul/files/0.6.0-gcc46.patch
new file mode 100644
index 000000000000..eb0ce26b6e1c
--- /dev/null
+++ b/app-emulation/gxemul/files/0.6.0-gcc46.patch
@@ -0,0 +1,16 @@
+ src/include/refcount_ptr.h | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/include/refcount_ptr.h b/src/include/refcount_ptr.h
+index 4645769..ebabd58 100644
+--- a/src/include/refcount_ptr.h
++++ b/src/include/refcount_ptr.h
+@@ -1,6 +1,8 @@
+ #ifndef REFCOUNT_PTR_H
+ #define REFCOUNT_PTR_H
+
++#include <stddef.h>
++
+ /*
+ * Copyright (C) 2007-2010 Anders Gavare. All rights reserved.
+ *
diff --git a/app-emulation/gxemul/gxemul-0.4.6.2.ebuild b/app-emulation/gxemul/gxemul-0.4.6.2.ebuild
deleted file mode 100644
index 43c5b2b32221..000000000000
--- a/app-emulation/gxemul/gxemul-0.4.6.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.6.2.ebuild,v 1.2 2008/02/21 18:06:08 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
-HOMEPAGE="http://gavare.se/gxemul/"
-SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="X"
-
-RDEPEND="X? ( x11-libs/libX11
- x11-libs/libXaw
- x11-libs/libXdmcp )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )"
-
-src_compile() {
- tc-export CC
- local myconf=""
-
- use X || myconf="${myconf} --disable-x"
-
- einfo "Configuring with: ${myconf}"
- ./configure ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- dobin gxemul || die "gxemul not found in ${S}"
- doman man/gxemul.1
- dodoc HISTORY LICENSE README RELEASE TODO
- dohtml doc/*
-}
diff --git a/app-emulation/gxemul/gxemul-0.4.7.ebuild b/app-emulation/gxemul/gxemul-0.4.7.ebuild
deleted file mode 100644
index 08d2771542dc..000000000000
--- a/app-emulation/gxemul/gxemul-0.4.7.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.7.ebuild,v 1.1 2009/01/04 12:07:15 armin76 Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
-HOMEPAGE="http://gavare.se/gxemul/"
-SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="X"
-
-RDEPEND="X? ( x11-libs/libX11
- x11-libs/libXaw
- x11-libs/libXdmcp )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )"
-
-src_compile() {
- tc-export CC
- local myconf=""
-
- use X || myconf="${myconf} --disable-x"
-
- einfo "Configuring with: ${myconf}"
- ./configure ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- dobin gxemul || die "gxemul not found in ${S}"
- doman man/gxemul.1
- dodoc HISTORY LICENSE README RELEASE TODO
- dohtml doc/*
-}
diff --git a/app-emulation/gxemul/gxemul-0.6.0.ebuild b/app-emulation/gxemul/gxemul-0.6.0.ebuild
index c8600835bdcb..f2c366e479db 100644
--- a/app-emulation/gxemul/gxemul-0.6.0.ebuild
+++ b/app-emulation/gxemul/gxemul-0.6.0.ebuild
@@ -1,39 +1,41 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.6.0.ebuild,v 1.1 2010/09/20 21:00:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.6.0.ebuild,v 1.2 2011/04/22 12:32:02 jlec Exp $
-EAPI="2"
+EAPI="4"
inherit eutils toolchain-funcs
-DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
HOMEPAGE="http://gxemul.sourceforge.net/"
SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="X"
+IUSE="debug X"
RDEPEND="X? ( x11-libs/libX11 )"
-
DEPEND="${RDEPEND}
X? ( x11-proto/xproto )"
src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
sed -i configure -e 's|-O3||g' || die "sed configure"
+ tc-export CC CXX
}
src_configure() {
- tc-export CC CXX
-
# no autotools
- ./configure $(use X || echo --disable-x) || die "configure failed"
+ ./configure \
+ --disable-valgrind \
+ $(use debug && echo --debug) \
+ $(use X || echo --disable-x) || die "configure failed"
}
src_install() {
- dobin gxemul || die
+ dobin gxemul
doman man/gxemul.1
- dodoc HISTORY README RELEASE TODO
- dohtml doc/*
+ dodoc HISTORY README
+ dohtml -r doc/*
}