summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/kvm')
-rw-r--r--app-emulation/kvm/ChangeLog35
-rw-r--r--app-emulation/kvm/kvm-77.ebuild (renamed from app-emulation/kvm/kvm-73.ebuild)38
2 files changed, 54 insertions, 19 deletions
diff --git a/app-emulation/kvm/ChangeLog b/app-emulation/kvm/ChangeLog
index 3c880dff0704..5e3f5c7afa8c 100644
--- a/app-emulation/kvm/ChangeLog
+++ b/app-emulation/kvm/ChangeLog
@@ -1,6 +1,39 @@
# ChangeLog for app-emulation/kvm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/ChangeLog,v 1.17 2008/09/15 14:14:32 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/ChangeLog,v 1.18 2008/10/21 01:01:55 dang Exp $
+
+*kvm-77 (21 Oct 2008)
+
+ 21 Oct 2008; Daniel Gryniewicz <dang@gentoo.org> -kvm-73.ebuild,
+ +kvm-77.ebuild:
+ Bump kvm to 77
+
+ - 2 important changes from a user's point of view:
+
+ - The minimum version of the kernel for non-module installs is now
+
+ 2.6.25.
+
+ - If you're building the modules, you need to have CONFIG_KVM enabled
+
+ in your kernel. This is because a type is not defined unless
+
+ CONFIG_KVM is set, and the compat code won't kick in unless you're
+
+ building completely outside the kernel tree (which we're not). - Important
+ upstream changes:
+
+ - Faster disk emulation
+
+ - Better handling of >4G of RAM
+
+ - Improved VNC
+
+ - Improved USB
+
+ - live migration fixes
+
+ - Speed improvements on 2.6.27+ hosts
15 Sep 2008; Daniel Gryniewicz <dang@gentoo.org> -kvm-71-r2.ebuild,
-kvm-72.ebuild, -kvm-72-r1.ebuild:
diff --git a/app-emulation/kvm/kvm-73.ebuild b/app-emulation/kvm/kvm-77.ebuild
index c279ee1393e3..1cc5b7cbe18e 100644
--- a/app-emulation/kvm/kvm-73.ebuild
+++ b/app-emulation/kvm/kvm-77.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/kvm-73.ebuild,v 1.2 2008/08/23 00:26:31 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/kvm-77.ebuild,v 1.1 2008/10/21 01:01:55 dang Exp $
inherit eutils flag-o-matic toolchain-funcs linux-mod
# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
-PATCHSET="kvm-patches-20080822"
+PATCHSET="kvm-patches-20081020"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
mirror://gentoo/${PATCHSET}.tar.gz"
@@ -40,6 +40,7 @@ DEPEND="${RDEPEND}
QA_TEXTRELS="usr/bin/kvm"
pkg_setup() {
+ linux-info_pkg_setup
if use havekernel && use modules ; then
ewarn "You have the 'havekernel' and 'modules' use flags enabled."
ewarn "'havekernel' trumps 'modules'; the kvm modules will not"
@@ -49,17 +50,24 @@ pkg_setup() {
ewarn "You have the 'havekernel' use flag set. This means you"
ewarn "must ensure you have a compatible kernel on your own."
elif use modules ; then
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
BUILD_TARGETS="all"
MODULE_NAMES="kvm(kvm:${S}/kernel:${S}/kernel/x86)"
MODULE_NAMES="${MODULE_NAMES} kvm-intel(kvm:${S}/kernel:${S}/kernel/x86)"
MODULE_NAMES="${MODULE_NAMES} kvm-amd(kvm:${S}/kernel:${S}/kernel/x86)"
linux-mod_pkg_setup
- elif kernel_is lt 2 6 22; then
- eerror "the kvm in your kernel requires an older version of"
- eerror "kvm as shown in :"
- eerror " http://kvm.qumranet.com/kvmwiki/Downloads"
- eerror "Either upgrade your kernel, or enable the 'modules'"
- eerror "USE flag."
+ elif kernel_is lt 2 6 25; then
+ eerror "This version of KVM requres a host kernel of 2.6.25 or higher."
+ eerror "Either upgrade your kernel, or enable the 'modules' USE flag."
die "kvm version not compatible"
elif ! linux_chkconfig_present KVM; then
eerror "Please enable KVM support in your kernel, found at:"
@@ -89,16 +97,10 @@ src_unpack() {
# avoid strip
sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' qemu/Makefile
- epatch \
- "${WORKDIR}/${PATCHSET}"/kvm-45-qemu-configure.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-61-qemu-kvm.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-qemu-kvm-cmdline.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-68-libkvm-no-kernel.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-ifup_ifdown.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-70-block-rw-range-check.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-73-qemu-no-blobs.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-73-qemu-kvm-doc.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-73-kernel-longmode.patch
+ # apply patchset
+ EPATCH_SOURCE="${WORKDIR}/${PATCHSET}"
+ EPATCH_SUFFIX="patch"
+ epatch
}
src_compile() {