summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog8
-rw-r--r--app-emulation/bochs/bochs-2.4.1.ebuild8
-rw-r--r--app-emulation/bochs/bochs-2.4.5.ebuild135
3 files changed, 146 insertions, 5 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 5d5cf1dd4158..c9a12996a3e6 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/bochs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.87 2010/02/10 06:32:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.88 2010/09/04 09:22:32 lu_zero Exp $
+
+*bochs-2.4.5 (04 Sep 2010)
+
+ 04 Sep 2010; Luca Barbato <lu_zero@gentoo.org> bochs-2.4.1.ebuild,
+ +bochs-2.4.5.ebuild:
+ New version and wx 2.8 support
10 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> bochs-2.3.ebuild,
bochs-2.3.6.ebuild, bochs-2.3.7.ebuild, bochs-2.4.1.ebuild:
diff --git a/app-emulation/bochs/bochs-2.4.1.ebuild b/app-emulation/bochs/bochs-2.4.1.ebuild
index ce26c06806e3..dfddb93a61f0 100644
--- a/app-emulation/bochs/bochs-2.4.1.ebuild
+++ b/app-emulation/bochs/bochs-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.4 2010/02/10 06:32:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.5 2010/09/04 09:22:32 lu_zero Exp $
inherit eutils wxwidgets
@@ -20,7 +20,7 @@ RDEPEND="X? ( x11-libs/libICE
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
- wxwidgets? ( =x11-libs/wxGTK-2.6* )
+ wxwidgets? ( =x11-libs/wxGTK-2.8* )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
@@ -42,10 +42,10 @@ src_unpack() {
}
src_compile() {
- WX_GTK_VER=2.6
+ WX_GTK_VER=2.8
use wxwidgets && \
- need-wxwidgets ansi
+ need-wxwidgets unicode
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
diff --git a/app-emulation/bochs/bochs-2.4.5.ebuild b/app-emulation/bochs/bochs-2.4.5.ebuild
new file mode 100644
index 000000000000..959784271c89
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.4.5.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.5.ebuild,v 1.1 2010/09/04 09:22:32 lu_zero Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
+
+RDEPEND="X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ wxwidgets? ( =x11-libs/wxGTK-2.8* )
+ readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ >=sys-apps/sed-4
+ >=app-text/opensp-1.5"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+
+ # we already downloaded dlxlinux4.tar.gz so let the Makefile cp it instead
+ # of downloading it again
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_compile() {
+ WX_GTK_VER=2.8
+
+ use wxwidgets && \
+ need-wxwidgets unicode
+
+ use x86 && \
+ myconf="--enable-idle-hack --enable-fast-function-calls"
+
+ use amd64 && \
+ myconf="--enable-x86-64"
+
+ use wxwidgets && \
+ myconf="${myconf} --with-wx"
+ use wxwidgets || \
+ myconf="${myconf} --without-wx"
+
+ use vnc && \
+ myconf="${myconf} --with-rfb"
+
+ use X && \
+ myconf="${myconf} --with-x11"
+
+ use ncurses && \
+ myconf="${myconf} --with-term"
+
+ # --enable-all-optimizations causes bus error on sparc :(
+ use sparc || \
+ myconf="${myconf} --enable-all-optimizations"
+
+ econf \
+ --enable-repeat-speedups \
+ --enable-trace-cache \
+ --enable-fast-function-calls \
+ --enable-disasm \
+ --enable-logging \
+ --enable-raw-serial \
+ --enable-vbe \
+ --enable-clgd54xx \
+ --enable-alignment-check \
+ --enable-monitor-mwait \
+ --enable-gameport \
+ --enable-iodebug \
+ --prefix=/usr \
+ --enable-ne2000 \
+ --enable-sb16=linux \
+ --enable-plugins \
+ --enable-cdrom \
+ --enable-pci \
+ --enable-pcidev \
+ --enable-pnic \
+ --enable-cpu-level=6 \
+ --enable-smp \
+ --with-nogui \
+ $(use_enable usb) \
+ $(use_enable readline) \
+ $(use_enable debugger) \
+ $(use_with X) \
+ $(use_with sdl) \
+ $(use_with svga) \
+ $(use_enable acpi) \
+ ${myconf} || \
+ die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install unpack_dlx || die "make install failed"
+
+ # workaround
+ make prefix="${D}/usr" install_dlx
+
+ dodoc \
+ CHANGES \
+ PARAM_TREE.txt \
+ README \
+ README-plugins \
+ TESTFORM.txt \
+ TODO || \
+ die "doco failed"
+
+ if [ use vnc ]
+ then
+ dodoc README.rfb || die "dodoc failed"
+ fi
+
+ if [ use wxwidgets ]
+ then
+ dodoc README-wxWindows || die "dodoc failed"
+ fi
+}