summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog7
-rw-r--r--app-editors/bluefish/bluefish-1.0.4-r1.ebuild39
-rw-r--r--app-editors/bluefish/files/digest-bluefish-1.0.4-r11
3 files changed, 46 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 6317af24cbc7..75326f89287c 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.51 2005/09/22 18:21:06 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.52 2005/12/20 22:34:51 hanno Exp $
+
+*bluefish-1.0.4-r1 (20 Dec 2005)
+
+ 20 Dec 2005; Hanno Boeck <hanno@gentoo.org> +bluefish-1.0.4-r1.ebuild:
+ Add gnome USE-flag.
*bluefish-1.0.4 (22 Sep 2005)
diff --git a/app-editors/bluefish/bluefish-1.0.4-r1.ebuild b/app-editors/bluefish/bluefish-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..4c643b6fe436
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.4-r1.ebuild,v 1.1 2005/12/20 22:34:51 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell gnome"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ gnome? ( gnome-base/libgnomeui )"
+
+src_compile() {
+ econf --disable-update-databases \
+ `use_enable nls` \
+ `use_with gnome libgnomeui` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ update-mime-database /usr/share/mime
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-1.0.4-r1 b/app-editors/bluefish/files/digest-bluefish-1.0.4-r1
new file mode 100644
index 000000000000..15e4b6fdd5ea
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-1.0.4-r1
@@ -0,0 +1 @@
+MD5 8d5c1b7315cdc935aa024954093d2b32 bluefish-1.0.4.tar.bz2 1469951