summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/eblook/eblook-1.6.1.ebuild')
-rw-r--r--app-dicts/eblook/eblook-1.6.1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/app-dicts/eblook/eblook-1.6.1.ebuild b/app-dicts/eblook/eblook-1.6.1.ebuild
index a1e448be0d72..2e6c3df160f5 100644
--- a/app-dicts/eblook/eblook-1.6.1.ebuild
+++ b/app-dicts/eblook/eblook-1.6.1.ebuild
@@ -1,28 +1,29 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/eblook/eblook-1.6.1.ebuild,v 1.6 2012/04/25 16:08:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/eblook/eblook-1.6.1.ebuild,v 1.7 2012/07/01 09:57:13 jlec Exp $
-IUSE=""
+EAPI=4
-DESCRIPTION="EBlook is an interactive search utility for electronic dictionaries"
+DESCRIPTION="Interactive search utility for electronic dictionaries"
HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${P/_/}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${P%_*}"
-src_compile() {
- econf --with-eb-conf=/etc/eb.conf
- emake || die
+src_prepare() {
+ sed \
+ -e 's:LDFAGS:LDFLAGS:g' \
+ -i configure || die
}
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README VERSION
+src_configure() {
+ econf --with-eb-conf=/etc/eb.conf
}