summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/sarab')
-rw-r--r--app-backup/sarab/ChangeLog10
-rw-r--r--app-backup/sarab/files/0.2.7-better-defaults-gentoo.patch23
-rw-r--r--app-backup/sarab/sarab-0.2.7.ebuild40
3 files changed, 71 insertions, 2 deletions
diff --git a/app-backup/sarab/ChangeLog b/app-backup/sarab/ChangeLog
index 02aad90dae19..cfe41a64b927 100644
--- a/app-backup/sarab/ChangeLog
+++ b/app-backup/sarab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/sarab
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/ChangeLog,v 1.10 2008/06/03 22:52:30 rbu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/ChangeLog,v 1.11 2009/03/31 21:48:28 bangert Exp $
+
+*sarab-0.2.7 (31 Mar 2009)
+
+ 31 Mar 2009; Thilo Bangert <bangert@gentoo.org>
+ +files/0.2.7-better-defaults-gentoo.patch, +sarab-0.2.7.ebuild:
+ version bump - bug #264169
*sarab-0.2.4 (03 Jun 2008)
diff --git a/app-backup/sarab/files/0.2.7-better-defaults-gentoo.patch b/app-backup/sarab/files/0.2.7-better-defaults-gentoo.patch
new file mode 100644
index 000000000000..88c3172027cb
--- /dev/null
+++ b/app-backup/sarab/files/0.2.7-better-defaults-gentoo.patch
@@ -0,0 +1,23 @@
+Index: sarab-0.2.7/etc/sarab.conf
+===================================================================
+--- sarab-0.2.7.orig/etc/sarab.conf
++++ sarab-0.2.7/etc/sarab.conf
+@@ -76,10 +76,10 @@
+
+ # The location of the DAR executable file
+ # This line is only effective if not added by install.sh later in this file
+-DAR_BINARY="/usr/local/bin/dar"
++DAR_BINARY="/usr/bin/dar"
+
+ # The location of the statically-compiled DAR executable file
+-DAR_STATIC="/usr/local/bin/dar_static"
++DAR_STATIC="/usr/bin/dar_static"
+
+ # The temporary directory name that backups will be created in. This will be created underneath $DESTINATION.
+ WORK_DIR=".sarab_temp_workdir"
+@@ -92,4 +92,4 @@
+ DAR_COMMAND="$DAR_BINARY --batch $SECURITY_CONFIG --batch $SARAB_ETC/$SARAB_DCF -c $DAR_CREATE --noconf -Q"
+
+ # Location and name of temporary log file
+-TEMP_LOG="$SARAB_ETC/sarab_temp.log"
++TEMP_LOG="/var/log/sarab_temp.log"
diff --git a/app-backup/sarab/sarab-0.2.7.ebuild b/app-backup/sarab/sarab-0.2.7.ebuild
new file mode 100644
index 000000000000..776e3f7dd349
--- /dev/null
+++ b/app-backup/sarab/sarab-0.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/sarab-0.2.7.ebuild,v 1.1 2009/03/31 21:48:28 bangert Exp $
+
+inherit eutils
+
+DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR."
+HOMEPAGE="http://sarab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-backup/dar
+ virtual/mailx"
+
+src_unpack() {
+ cd "${S}"
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${PV}-better-defaults-gentoo.patch
+}
+
+src_install() {
+ dobin sarab.sh
+ insinto /etc/sarab
+ doins -r etc/*
+ # sarab.conf could contain passphrase information
+ fperms 600 /etc/sarab/sarab.conf
+ dodoc CHANGELOG FAQ INSTALL README
+ dodoc "${FILESDIR}"/README.Gentoo
+}
+
+pkg_postinstl() {
+ ewarn "The configuration format for DAR encryption has changed in Sarab 0.2.4."
+ ewarn "Replace DAR_ENCRYPTION_OPTIONS=\"--key blowfish:PASSPHRASE\""
+ ewarn "by SARAB_KEY=\"blowfish:PASSPHRASE\" in /etc/sarab/sarab.conf"
+}