summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/ChangeLog8
-rw-r--r--app-arch/rpm/files/digest-rpm-4.4.13
-rw-r--r--app-arch/rpm/files/rpm-4.4.1-ubuntu-fixup.patch215
-rw-r--r--app-arch/rpm/rpm-4.4.1.ebuild101
4 files changed, 326 insertions, 1 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 7761f948d6cb..f477b49ca6b9 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/rpm
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.53 2006/04/27 09:25:15 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.54 2006/06/03 23:19:22 lu_zero Exp $
+
+*rpm-4.4.1 (03 Jun 2006)
+
+ 03 Jun 2006; Luca Barbato <lu_zero@gentoo.org>
+ +files/rpm-4.4.1-ubuntu-fixup.patch, +rpm-4.4.1.ebuild:
+ New version, hopefully builds
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-rpm-4.0.4-r5,
files/digest-rpm-4.2, files/digest-rpm-4.2.1, Manifest:
diff --git a/app-arch/rpm/files/digest-rpm-4.4.1 b/app-arch/rpm/files/digest-rpm-4.4.1
new file mode 100644
index 000000000000..2013664b71ca
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-4.4.1
@@ -0,0 +1,3 @@
+MD5 90ded9047b1b69d918c6c7c7b56fd7a9 rpm-4.4.1.tar.gz 11497447
+RMD160 b2b34d678c4707c1c1bf8e05e7b92a8956bb4226 rpm-4.4.1.tar.gz 11497447
+SHA256 4a5e2a5a64a47344b6447b54e046b8550ea7ee99344eee3e8d4c087cb148552b rpm-4.4.1.tar.gz 11497447
diff --git a/app-arch/rpm/files/rpm-4.4.1-ubuntu-fixup.patch b/app-arch/rpm/files/rpm-4.4.1-ubuntu-fixup.patch
new file mode 100644
index 000000000000..339f0b435024
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.4.1-ubuntu-fixup.patch
@@ -0,0 +1,215 @@
+--- rpm-4.4.1.orig/configure.ac
++++ rpm-4.4.1/configure.ac
+@@ -1180,9 +1180,9 @@
+
+ dnl XXX Choose /usr/lib or /usr/lib64 for library installs.
+ MARK64=
+-case "${target_cpu}" in
+-x86_64*|ppc64*|powerpc64*|sparc64*|s390x*) MARK64=64 ;;
+-esac
++dnl case "${target_cpu}" in
++dnl x86_64*|ppc64*|powerpc64*|sparc64*|s390x*) MARK64=64 ;;
++dnl esac
+ AC_SUBST(MARK64)
+
+ dnl Determine the canonical arch-vendor-os for the build machine
+--- rpm-4.4.1.orig/po/de.po
++++ rpm-4.4.1/po/de.po
+@@ -190,7 +190,7 @@
+ #: rpmqv.c:370
+ msgid "one type of query/verify may be performed at a time"
+ msgstr ""
+-"Nur nur eine Art der Anfrage/Überprüfung kann pro Programmlauf durchgeführt "
++"Nur eine Art der Anfrage/Überprüfung kann pro Programmlauf durchgeführt "
+ "werden"
+
+ #: rpmqv.c:374
+@@ -4612,7 +4612,7 @@
+
+ # oder besser: "... verletzen" ?
+ #~ msgid "removing these packages would break dependencies:\n"
+-#~ msgstr "Das Enfernen dieser Pakete würde Paket-Abhängigkeiten missachten:\n"
++#~ msgstr "Das Entfernen dieser Pakete würde Paket-Abhängigkeiten missachten:\n"
+
+ #, fuzzy
+ #~ msgid "package %s has unsatisfied Requires: %s\n"
+@@ -5520,7 +5520,7 @@
+
+ #, fuzzy
+ #~ msgid "rename of %s to %s failed: %s\n"
+-#~ msgstr "umbennen von %s nach %s fehlgeschlagen: %s"
++#~ msgstr "umbenennen von %s nach %s fehlgeschlagen: %s"
+
+ #, fuzzy
+ #~ msgid "removal of %s failed: %s\n"
+--- rpm-4.4.1.orig/lib/depends.c
++++ rpm-4.4.1/lib/depends.c
+@@ -1294,14 +1294,12 @@
+ switch (rpmteType(p)) {
+ case TR_REMOVED:
+ /* Skip if not %preun/%postun requires or legacy prereq. */
+- if (isInstallPreReq(Flags)
+- || !( isErasePreReq(Flags) || isLegacyPreReq(Flags) ) )
++ if (!( isErasePreReq(Flags) || isLegacyPreReq(Flags) ) )
+ /*@innercontinue@*/ continue;
+ /*@switchbreak@*/ break;
+ case TR_ADDED:
+ /* Skip if not %pre/%post requires or legacy prereq. */
+- if (isErasePreReq(Flags)
+- || !( isInstallPreReq(Flags) || isLegacyPreReq(Flags) ) )
++ if (!( isInstallPreReq(Flags) || isLegacyPreReq(Flags) ) )
+ /*@innercontinue@*/ continue;
+ /*@switchbreak@*/ break;
+ }
+--- rpm-4.4.1.orig/python/header-py.c
++++ rpm-4.4.1/python/header-py.c
+@@ -477,7 +477,7 @@
+ while (extensions->name) {
+ if (extensions->type == HEADER_EXT_TAG
+ && !xstrcasecmp(extensions->name + 7, str)) {
+- (const struct headerSprintfExtension *) ext = extensions;
++ ext = extensions;
+ }
+ extensions++;
+ }
+--- rpm-4.4.1.orig/lsb-rpm.1
++++ rpm-4.4.1/lsb-rpm.1
+@@ -0,0 +1,16 @@
++.TH LSB-RPM 1
++.SH NAME
++lsb-rpm \- build a LSB package
++.SH SYNOPSIS
++.B lsb-rpm -b package.spec
++.SH "DESCRIPTION"
++This is a special version of rpm that can only be used to build RPM v3
++format packages, for use as LSB packages. It cannot query or install
++packages, just build them. See the BUILD OPTIONS section of
++.BR rpm (8)
++for the details.
++.SH "SEE ALSO"
++.BR rpm (8)
++.SH AUTHOR
++This manual page was written by Joey Hess,
++for the Debian GNU/Linux system.
+--- rpm-4.4.1.orig/macros.in
++++ rpm-4.4.1/macros.in
+@@ -218,7 +218,7 @@
+ %_tmppath %{_var}/tmp
+
+ # Path to top of build area.
+-%_topdir %{_usrsrc}/redhat
++%_topdir %{_usrsrc}/rpm
+
+ # The path to the unzip executable (legacy, use %{__unzip} instead).
+ %_unzipbin %{__unzip}
+@@ -658,8 +658,8 @@
+
+ # Horowitz Key Protocol server configuration
+ #
+-%_hkp_keyserver hkp://pgp.mit.edu
+-%_hkp_keyserver_query %{_hkp_keyserver}/pks/lookup?op=get&search=0x
++#%_hkp_keyserver hkp://pgp.mit.edu
++#%_hkp_keyserver_query %{_hkp_keyserver}/pks/lookup?op=get&search=0x
+
+ #==============================================================================
+ # ---- Transaction macros.
+@@ -1058,15 +1058,15 @@
+ %_sbindir %{_exec_prefix}/sbin
+ %_libexecdir %{_exec_prefix}/libexec
+ %_datadir %{_prefix}/share
+-%_sysconfdir %{_prefix}/etc
++%_sysconfdir /etc
+ %_sharedstatedir %{_prefix}/com
+-%_localstatedir %{_prefix}/var
++%_localstatedir /var
+ %_lib lib
+ %_libdir %{_exec_prefix}/%{_lib}
+ %_includedir %{_prefix}/include
+ %_oldincludedir /usr/include
+-%_infodir %{_prefix}/info
+-%_mandir %{_prefix}/man
++%_infodir /usr/share/info
++%_mandir /usr/share/man
+
+ #==============================================================================
+ # ---- config.guess platform macros.
+--- rpm-4.4.1.orig/platform.in
++++ rpm-4.4.1/platform.in
+@@ -28,7 +28,7 @@
+ %_oldincludedir @oldincludedir@
+ %_infodir @infodir@
+ %_mandir @mandir@
+-%_initrddir %{_sysconfdir}/rc.d/init.d
++%_initrddir %{_sysconfdir}/init.d
+
+ %_defaultdocdir @DEFAULTDOCDIR@
+
+--- rpm-4.4.1.orig/lib/poptI.c
++++ rpm-4.4.1/lib/poptI.c
+@@ -16,8 +16,7 @@
+ /*@unchecked@*/
+ struct rpmInstallArguments_s rpmIArgs = {
+ 0, /* transFlags */
+- /* probFilter */
+- (RPMPROB_FILTER_REPLACEOLDFILES | RPMPROB_FILTER_REPLACENEWFILES),
++ 0, /* probFilter */
+ 0, /* installInterfaceFlags */
+ 0, /* eraseInterfaceFlags */
+ 0, /* qva_flags */
+--- rpm-4.4.1.orig/lib/rpmal.c
++++ rpm-4.4.1/lib/rpmal.c
+@@ -744,7 +744,7 @@
+
+ /*@-branchstate@*/ /* FIX: ret is a problem */
+ for (found = 0, ret = NULL;
+- die <= al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
++ die < al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
+ die++)
+ {
+
+--- rpm-4.4.1.orig/rpmio/rpmio.h
++++ rpm-4.4.1/rpmio/rpmio.h
+@@ -637,7 +637,7 @@
+ /*@unused@*/ int timedRead(FD_t fd, /*@out@*/ void * bufptr, int length)
+ /*@globals fileSystem @*/
+ /*@modifies fd, *bufptr, fileSystem @*/;
+-#define timedRead ufdio->read
++#define timedRead (ufdio->read)
+
+ /*@-exportlocal@*/
+ /**
+--- rpm-4.4.1.orig/lib/rpmlib.h
++++ rpm-4.4.1/lib/rpmlib.h
+@@ -501,8 +501,7 @@
+ RPMSENSE_EQUAL = (1 << 3),
+ RPMSENSE_PROVIDES = (1 << 4), /* only used internally by builds */
+ RPMSENSE_CONFLICTS = (1 << 5), /* only used internally by builds */
+- /* bit 6 used to be RPMSENSE_PREREQ */
+-#define RPMSENSE_PREREQ RPMSENSE_ANY
++ RPMSENSE_PREREQ = (1 << 6), /*!< @todo Legacy. */
+ RPMSENSE_OBSOLETES = (1 << 7), /* only used internally by builds */
+ RPMSENSE_INTERP = (1 << 8), /*!< Interpreter used by scriptlet. */
+ RPMSENSE_SCRIPT_PRE = ((1 << 9)|RPMSENSE_PREREQ), /*!< %pre dependency. */
+--- rpm-4.4.1.orig/python/rpmmodule.c
++++ rpm-4.4.1/python/rpmmodule.c
+@@ -293,7 +293,7 @@
+
+ while (extensions->name) {
+ if (extensions->type == HEADER_EXT_TAG) {
+- (const struct headerSprintfExtension *) ext = extensions;
++ ext = extensions;
+ PyDict_SetItemString(d, (char *) extensions->name, o=PyCObject_FromVoidPtr(ext, NULL));
+ Py_DECREF(o);
+ PyDict_SetItem(dict, tag, o=PyString_FromString(ext->name + 7));
+--- rpm-4.4.1.orig/lib/transaction.c
++++ rpm-4.4.1/lib/transaction.c
+@@ -2285,7 +2285,7 @@
+ p->fi = rpmfiFree(p->fi);
+
+ /* If no post-transaction script, then don't bother. */
+- if (haspostscript)
++ if (!haspostscript)
+ continue;
+
+ p->fd = ts->notify(p->h, RPMCALLBACK_INST_OPEN_FILE, 0, 0,
+
diff --git a/app-arch/rpm/rpm-4.4.1.ebuild b/app-arch/rpm/rpm-4.4.1.ebuild
new file mode 100644
index 000000000000..6fb2ecfa6783
--- /dev/null
+++ b/app-arch/rpm/rpm-4.4.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.1.ebuild,v 1.1 2006/06/03 23:19:22 lu_zero Exp $
+
+inherit python flag-o-matic libtool eutils
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha -amd64 ~arm ~hppa ~ia64 ~mips ~ppc -ppc64 ~s390 ~sh ~sparc -x86"
+IUSE="nls python doc"
+
+RDEPEND="=sys-libs/db-3.2*
+ >=sys-libs/zlib-1.1.3
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ >=dev-libs/beecrypt-3.1.0-r1
+ python? ( >=dev-lang/python-2.2 )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/rpm-4.4.1-ubuntu-fixup.patch
+ cd ${S}
+ elibtoolize
+ libtoolize --copy --force
+}
+
+src_compile() {
+ strip-flags
+
+ unset LD_ASSUME_KERNEL
+ local myconf
+ myconf="--enable-posixmutexes --without-javaglue --without-selinux"
+
+ python_version
+ use python \
+ && myconf="${myconf} --with-python=${PYVER}" \
+ || myconf="${myconf} --without-python"
+
+ econf ${myconf} `use_enable nls` || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ mv ${D}/bin/rpm ${D}/usr/bin
+ mv ${D}/bin/rpmbuild ${D}/usr/bin
+ rm -rf ${D}/bin
+ # Fix for bug #8578 (app-arch/rpm create dead symlink)
+ # Local RH 7.3 install has no such symlink anywhere
+ # ------
+ # UPDATE for 4.1!
+ # There is a /usr/lib/rpm/rpmpopt-4.1 now
+ # the symlink is still created incorrectly. ???
+ rm -f ${D}/usr/lib/rpmpopt
+ rm -f ${D}/usr/lib/libpopt*
+ rm -f ${D}/usr/include/popt.h
+ use nls && rm -f ${D}/usr/share/locale/*/LC_MESSAGES/popt.mo
+ rm -f ${D}/usr/share/man/man3/popt*
+
+ keepdir /var/lib/rpm
+ keepdir /usr/src/pc/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+ keepdir /usr/src/pc/RPMS/{noarch,i{3,4,5,6}86,athlon}
+ keepdir /usr/src/pc
+ dodoc CHANGES CREDITS GROUPS README* RPM* TODO
+
+ use nls || rm -rf ${D}/usr/share/man/{ko,ja,fr,pl,ru,sk}
+
+ # create /usr/src/redhat/ and co for rpmbuild
+ for d in /usr/src/redhat/{BUILD,RPMS,SOURCES,SPECS,SRPMS}; do
+ dodir "${d}"
+ done
+}
+
+pkg_postinst() {
+ if [ -f ${ROOT}/var/lib/rpm/Packages ]; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ ${ROOT}/usr/bin/rpm --rebuilddb --root=${ROOT}
+ else
+ einfo "No RPM database found... Creating database..."
+ ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
+ fi
+
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/rpmdb
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}