summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/ChangeLog7
-rw-r--r--app-arch/lzma/lzma-4.43.ebuild22
2 files changed, 13 insertions, 16 deletions
diff --git a/app-arch/lzma/ChangeLog b/app-arch/lzma/ChangeLog
index ee40c1fdff5e..255f9aca255c 100644
--- a/app-arch/lzma/ChangeLog
+++ b/app-arch/lzma/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/lzma
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.4 2006/08/27 16:35:04 radek Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.5 2007/10/07 17:29:03 vapier Exp $
+
+ 07 Oct 2007; Mike Frysinger <vapier@gentoo.org> lzma-4.43.ebuild:
+ Cleanup ebuild.
*lzma-4.43 (27 Aug 2006)
diff --git a/app-arch/lzma/lzma-4.43.ebuild b/app-arch/lzma/lzma-4.43.ebuild
index cbfc29d0339c..d0a8ea503a9d 100644
--- a/app-arch/lzma/lzma-4.43.ebuild
+++ b/app-arch/lzma/lzma-4.43.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.43.ebuild,v 1.2 2007/07/15 05:44:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.43.ebuild,v 1.3 2007/10/07 17:29:03 vapier Exp $
inherit toolchain-funcs
@@ -10,27 +10,21 @@ SRC_URI="mirror://sourceforge/sevenzip/${PN}443.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~mips ~ppc-macos ~x86 ~amd64"
+KEYWORDS="~amd64 ~mips ~ppc-macos ~x86"
IUSE="doc"
-src_unpack() {
- mkdir ${S}
- cd ${S}
- unpack ${A}
-}
+S=${WORKDIR}
src_compile() {
cd C/7zip/Compress/LZMA_Alone
emake -f makefile.gcc \
CXX="$(tc-getCXX) ${CXXFLAGS}" \
CXX_C="$(tc-getCC) ${CFLAGS}" \
- || die "Make failed"
+ || die "Make failed"
}
src_install() {
- dobin C/7zip/Compress/LZMA_Alone/lzma
- if use doc; then
- dodoc *.txt
- dohtml *.html
- fi
+ dobin C/7zip/Compress/LZMA_Alone/lzma || die
+ dodoc history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt lzma.txt Methods.txt
}