summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/ChangeLog7
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.93
-rw-r--r--app-arch/gzip/gzip-1.3.9.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 6c0121dcc436..6757c66b4691 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/gzip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.72 2006/12/09 08:05:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.73 2006/12/16 03:08:25 vapier Exp $
+
+*gzip-1.3.9 (16 Dec 2006)
+
+ 16 Dec 2006; Mike Frysinger <vapier@gentoo.org> +gzip-1.3.9.ebuild:
+ Version bump.
*gzip-1.3.8 (09 Dec 2006)
diff --git a/app-arch/gzip/files/digest-gzip-1.3.9 b/app-arch/gzip/files/digest-gzip-1.3.9
new file mode 100644
index 000000000000..c460a0c92543
--- /dev/null
+++ b/app-arch/gzip/files/digest-gzip-1.3.9
@@ -0,0 +1,3 @@
+MD5 7cf923b24b718c418e85a283b2260e14 gzip-1.3.9.tar.gz 420737
+RMD160 27e28003bef96cdf195717c41a8ea16561576cb0 gzip-1.3.9.tar.gz 420737
+SHA256 a6fdbe5ce21f5e4ce219375c29e842da517e61a56900a678cf258b4fdd603e72 gzip-1.3.9.tar.gz 420737
diff --git a/app-arch/gzip/gzip-1.3.9.ebuild b/app-arch/gzip/gzip-1.3.9.ebuild
new file mode 100644
index 000000000000..65fe9d3c5e3a
--- /dev/null
+++ b/app-arch/gzip/gzip-1.3.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.9.ebuild,v 1.1 2006/12/16 03:08:25 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="mirror://gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static pic"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
+ dosym /bin/gunzip /usr/bin/gunzip || die
+}