summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/jinit/jinit-0.1.12.ebuild')
-rw-r--r--app-admin/jinit/jinit-0.1.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/jinit/jinit-0.1.12.ebuild b/app-admin/jinit/jinit-0.1.12.ebuild
new file mode 100644
index 000000000000..419c3429dae6
--- /dev/null
+++ b/app-admin/jinit/jinit-0.1.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/jinit/jinit-0.1.12.ebuild,v 1.1 2004/12/31 04:11:15 chriswhite Exp $
+
+DESCRIPTION="An alternative to sysvinit which supports the need(8) concept"
+HOMEPAGE="http://homepage.ntlworld.com/john.fremlin/programs/linux/jinit/ http://www.atnf.csiro.au/~rgooch/linux/boot-scripts/"
+SRC_URI="http://homepage.ntlworld.com/john.fremlin/programs/linux/jinit/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/sbin ${D}/
+ mv ${D}/sbin/init ${D}/sbin/jinit
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ cp -R example-setup ${D}/usr/share/doc/${PF}/
+
+ #find ${D}/usr/share/doc/${PF}/example-setup -name "Makefile*"
+}