summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/drod-bin/ChangeLog10
-rw-r--r--games-puzzle/drod-bin/Manifest6
-rw-r--r--games-puzzle/drod-bin/drod-bin-1.6.3.ebuild31
-rw-r--r--games-puzzle/drod-bin/files/digest-drod-bin-1.6.31
-rw-r--r--games-puzzle/drod-bin/files/install.patch25
-rw-r--r--games-puzzle/drod-bin/metadata.xml9
6 files changed, 79 insertions, 3 deletions
diff --git a/games-puzzle/drod-bin/ChangeLog b/games-puzzle/drod-bin/ChangeLog
new file mode 100644
index 000000000000..4c79450741b1
--- /dev/null
+++ b/games-puzzle/drod-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/drod-bin
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/drod-bin/ChangeLog,v 1.1 2003/11/19 08:54:00 mr_bones_ Exp $
+
+*drod-bin-1.6.3 (19 Nov 2003)
+
+ 19 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> drod-bin-1.6.3.ebuild,
+ files/install.patch:
+ initial commit; ebuild supplied by James Gibson via bug 33207 (modified)
+
diff --git a/games-puzzle/drod-bin/Manifest b/games-puzzle/drod-bin/Manifest
index d909c21992b1..6ffba4bbedde 100644
--- a/games-puzzle/drod-bin/Manifest
+++ b/games-puzzle/drod-bin/Manifest
@@ -1,5 +1,5 @@
-MD5 cf564e60b203516d5a0e5f8709ae3e7c install.log 30861
-MD5 d23234188d545847499ccbb986b5ec17 drod-bin-1.6.3.ebuild 787
-MD5 2e04744f644cdc550e42341693f1d8c2 files/setup-input 4
+MD5 10d24804fae3324dd185bc4323d656bf drod-bin-1.6.3.ebuild 967
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 57ba3e8f24b9dd30dc1bb95a55c2ed22 ChangeLog 435
MD5 1d60558af7a36a55cb912df26fd8f3c4 files/digest-drod-bin-1.6.3 71
MD5 da1e0cc0f61832593d45d38a7c04e852 files/install.patch 695
diff --git a/games-puzzle/drod-bin/drod-bin-1.6.3.ebuild b/games-puzzle/drod-bin/drod-bin-1.6.3.ebuild
new file mode 100644
index 000000000000..cd14e1fe1678
--- /dev/null
+++ b/games-puzzle/drod-bin/drod-bin-1.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/drod-bin/drod-bin-1.6.3.ebuild,v 1.1 2003/11/19 08:54:00 mr_bones_ Exp $
+
+inherit eutils games
+
+S="${WORKDIR}"
+DESCRIPTION="Deadly Rooms Of Death: face room upon room of deadly things, armed with only your sword and your wits"
+HOMEPAGE="http://www.drod.net"
+SRC_URI="mirror://sourceforge/drod/CDROD-${PV}-setup.sh.bin"
+
+KEYWORDS="-* x86"
+LICENSE="MPL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/x11"
+
+src_unpack() {
+ unpack_makeself ${A}
+ cd ${S}
+ epatch ${FILESDIR}/install.patch
+}
+
+src_install() {
+ ./install.sh -R ${D} -g -rl -pg -I || die "install.sh failed"
+ dodir "${GAMES_BINDIR}" || die "dodir failed"
+ dosym /opt/drod/bin/drod "${GAMES_BINDIR}/drod" || die "dosym failed"
+ prepgamesdirs
+ fperms 775 /opt/drod/bin/Data/ || die "fperms failed"
+}
diff --git a/games-puzzle/drod-bin/files/digest-drod-bin-1.6.3 b/games-puzzle/drod-bin/files/digest-drod-bin-1.6.3
new file mode 100644
index 000000000000..3ee99b96c9cb
--- /dev/null
+++ b/games-puzzle/drod-bin/files/digest-drod-bin-1.6.3
@@ -0,0 +1 @@
+MD5 55e9f532c32a63f270bf83a3de403539 CDROD-1.6.3-setup.sh.bin 13617144
diff --git a/games-puzzle/drod-bin/files/install.patch b/games-puzzle/drod-bin/files/install.patch
new file mode 100644
index 000000000000..cc3ffab9aa2c
--- /dev/null
+++ b/games-puzzle/drod-bin/files/install.patch
@@ -0,0 +1,25 @@
+--- CDROD-1.6.3/install.sh 2003-11-11 17:29:05.000000000 -0800
++++ CDROD-1.6.3-gentoo/install.sh 2003-11-14 15:44:22.000000000 -0800
+@@ -182,6 +182,14 @@
+ I_DOCDIR=$I_PREFIX/share/doc/$DROD_VERSION
+ }
+
++function set_gentoo {
++ I_RESDIR=/opt/drod/bin
++ I_DATDIR=/opt/drod/bin/Data
++ I_LIBDIR=/opt/drod/lib
++ I_DOCDIR=/opt/drod/doc
++ I_BINDIR=/opt/drod/bin
++}
++
+ function read_otherdir {
+ eval olddir=\$$2
+ read_dir $1 $2
+@@ -612,6 +620,7 @@
+ -d) shift; get_dir_opt I_DATDIR $1;;
+ -s) shift; get_dir_opt I_BINDIR $1; set_prefix; set_single;;
+ -u) shift; get_dir_opt I_BINDIR $1; set_prefix; set_usrstyle;;
++ -g) set_gentoo;;
+ -al) set_all_libs;;
+ -nl) set_no_libs;;
+ -rl) set_req_libs;;
diff --git a/games-puzzle/drod-bin/metadata.xml b/games-puzzle/drod-bin/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-puzzle/drod-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>