summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/safecat/ChangeLog5
-rw-r--r--net-mail/safecat/safecat-1.11.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/net-mail/safecat/ChangeLog b/net-mail/safecat/ChangeLog
index a5131df683bc..ff1049057a2c 100644
--- a/net-mail/safecat/ChangeLog
+++ b/net-mail/safecat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/safecat
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.10 2005/03/21 01:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.11 2005/03/22 04:14:31 agriffis Exp $
+
+ 22 Mar 2005; <agriffis@gentoo.org> safecat-1.11.ebuild:
+ Use toolchain functions instead of $CC et al
19 Mar 2005; Aron Griffis <agriffis@gentoo.org> safecat-1.11.ebuild:
Stable on alpha amd64 ia64 x86
diff --git a/net-mail/safecat/safecat-1.11.ebuild b/net-mail/safecat/safecat-1.11.ebuild
index 678a7b080035..33e036b8fa9a 100644
--- a/net-mail/safecat/safecat-1.11.ebuild
+++ b/net-mail/safecat/safecat-1.11.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.10 2005/03/19 15:25:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.11 2005/03/22 04:14:31 agriffis Exp $
-IUSE=""
+inherit fixheadtails eutils toolchain-funcs
-inherit fixheadtails eutils
+IUSE=""
DESCRIPTION="Safecat implements qmail's maildir algorithm, copying standard input safely to a specified directory."
-HOMEPAGE="http://budney.homeunix.net:8080/users/budney/linux/software/${PN}/"
+HOMEPAGE="http://budney.homeunix.net:8080/users/budney/linux/software/safecat/"
SRC_URI="http://budney.homeunix.net:8080/users/budney/linux/software/${PN}/${P}.tar.gz"
DEPEND="virtual/libc
@@ -26,15 +26,16 @@ src_unpack() {
cd ${S}
echo "/usr" > conf-root
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
ht_fix_file Makefile make-compile.sh
-}
-src_compile() {
egrep -v 'man|doc' hier.c > hier.c.new
mv hier.c.new hier.c
+}
+
+src_compile() {
make it man || die
}