summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/zfs-fuse/ChangeLog10
-rw-r--r--sys-fs/zfs-fuse/files/0.5.0/fix_zdb_path.patch11
-rw-r--r--sys-fs/zfs-fuse/files/0.5.0/fix_zfs-fuse_path.patch13
-rw-r--r--sys-fs/zfs-fuse/files/0.5.0/fix_ztest_path.patch9
-rw-r--r--sys-fs/zfs-fuse/files/0.5.0/zfs-fuse.rc43
-rw-r--r--sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild101
6 files changed, 186 insertions, 1 deletions
diff --git a/sys-fs/zfs-fuse/ChangeLog b/sys-fs/zfs-fuse/ChangeLog
index 0410ead42209..1ffcd58abb08 100644
--- a/sys-fs/zfs-fuse/ChangeLog
+++ b/sys-fs/zfs-fuse/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/zfs-fuse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.6 2008/09/25 16:29:02 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.7 2008/09/25 17:03:20 trapni Exp $
+
+*zfs-fuse-0.5.0 (25 Sep 2008)
+
+ 25 Sep 2008; Christian Parpart <trapni@gentoo.org>
+ +files/0.5.0/fix_zdb_path.patch, +files/0.5.0/fix_zfs-fuse_path.patch,
+ +files/0.5.0/fix_ztest_path.patch, +files/0.5.0/zfs-fuse.rc,
+ +zfs-fuse-0.5.0.ebuild:
+ added 0.5.0 release
25 Sep 2008; Christian Parpart <trapni@gentoo.org> files/9999/zfs-fuse.rc,
zfs-fuse-9999.ebuild:
diff --git a/sys-fs/zfs-fuse/files/0.5.0/fix_zdb_path.patch b/sys-fs/zfs-fuse/files/0.5.0/fix_zdb_path.patch
new file mode 100644
index 000000000000..770c1ae9dcf3
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/0.5.0/fix_zdb_path.patch
@@ -0,0 +1,11 @@
+--- a/src/cmd/ztest/ztest.c 2008-06-24 13:52:22.000000000 -0400
++++ b/src/cmd/ztest/ztest.c 2008-06-24 14:59:06.000000000 -0400
+@@ -2844,7 +2844,7 @@
+ /* zfs-fuse: ztest is never installed, so zdb should be in ../zdb/ */
+ /* LINTED */
+ (void) sprintf(zdb,
+- "../zdb/zdb -bc%s%s -U /tmp/zpool.cache -O %s %s",
++ "/usr/sbin/zdb -bc%s%s -U -O %s %s",
+ zopt_verbose >= 3 ? "s" : "",
+ zopt_verbose >= 4 ? "v" : "",
+ ztest_random(2) == 0 ? "pre" : "post", pool);
diff --git a/sys-fs/zfs-fuse/files/0.5.0/fix_zfs-fuse_path.patch b/sys-fs/zfs-fuse/files/0.5.0/fix_zfs-fuse_path.patch
new file mode 100644
index 000000000000..3b5d656f5744
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/0.5.0/fix_zfs-fuse_path.patch
@@ -0,0 +1,13 @@
+--- a/src/zfs-fuse/run.sh 2007-01-09 11:07:35.000000000 +0000
++++ b/src/zfs-fuse/run.sh 2007-01-09 11:45:05.000000000 +0000
+@@ -1,5 +1,7 @@
+ #!/bin/sh
+-
++echo ""
++echo "On Gentoo ZFS-FUSE runs in debugging mode by default."
++echo "To run ZFS-FUSE without debugging please run /usr/bin/run-zfs-fuse"
+ ulimit -c unlimited
+-
+-./zfs-fuse --no-daemon
++echo ""
++/usr/bin/run-zfs-fuse
diff --git a/sys-fs/zfs-fuse/files/0.5.0/fix_ztest_path.patch b/sys-fs/zfs-fuse/files/0.5.0/fix_ztest_path.patch
new file mode 100644
index 000000000000..d87979d4391c
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/0.5.0/fix_ztest_path.patch
@@ -0,0 +1,9 @@
+--- a/src/cmd/ztest/runtest.sh 2007-01-09 11:07:35.000000000 +0000
++++ b/src/cmd/ztest/runtest.sh 2007-01-09 11:08:51.000000000 +0000
+@@ -3,5 +3,5 @@ ulimit -c unlimited
+ echo "Start date: `date`"
+ #ZFS_DEBUG=on /usr/bin/time -v nice -n 20 ./ztest -V -T 86400 &> log.txt
+ #/usr/bin/time -v nice -n 20 ./ztest -V -T 86400
+-nice -n 20 ./ztest -V $* && echo Test successful
++nice -n 20 /usr/sbin/run-ztest -V $* && echo Test successful
+ echo "End date: `date`"
diff --git a/sys-fs/zfs-fuse/files/0.5.0/zfs-fuse.rc b/sys-fs/zfs-fuse/files/0.5.0/zfs-fuse.rc
new file mode 100644
index 000000000000..94648c91fa49
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/0.5.0/zfs-fuse.rc
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/files/0.5.0/zfs-fuse.rc,v 1.1 2008/09/25 17:03:20 trapni Exp $
+
+depend() {
+ need localmount
+ before net
+}
+
+PIDFILE="/var/run/zfs/zfs-fuse.pid"
+EXEFILE="/usr/sbin/zfs-fuse"
+
+checksystem() {
+ return 0 # TODO
+}
+
+start() {
+ ebegin "Starting ZFS-FUSE"
+ checksystem || return 1
+ start-stop-daemon --start --exec ${EXEFILE} \
+ --user daemon --group disk -- --pidfile ${PIDFILE}
+ rv=$?
+ eend $rv
+
+ if [[ $rv -eq 0 ]]; then
+ ebegin "Mounting ZFS filesystems"
+ zfs mount -a
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Unmounting ZFS filesystems"
+ zfs umount -f -a
+ eend $?
+
+ ebegin "Stopping ZFS-FUSE"
+ checksystem || return 2
+ start-stop-daemon --stop --pidfile ${PIDFILE} \
+ --exec ${EXEFILE} --retry TERM/1/TERM/2/TERM/4/TERM/8/KILL
+ eend $?
+}
diff --git a/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild b/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild
new file mode 100644
index 000000000000..6cbba152850e
--- /dev/null
+++ b/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild,v 1.1 2008/09/25 17:03:20 trapni Exp $
+
+IUSE="doc debug"
+
+inherit eutils
+
+DESCRIPTION="An implementation of the ZFS filesystem for FUSE/Linux"
+HOMEPAGE="http://www.wizy.org/wiki/ZFS_on_FUSE"
+#SRC_URI="http://download.berlios.de/zfs-fuse/zfs-fuse-${PV}.tar.bz2"
+SRC_URI="mirror://berlios/zfs-fuse/zfs-fuse-${PV}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-libs/glibc-2.3.3
+ >=dev-util/scons-0.96.1
+ >=dev-libs/libaio-0.3
+ >=sys-fs/fuse-2.6.1"
+
+RDEPEND=">=sys-fs/fuse-2.6.1"
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}/fix_zdb_path.patch"
+ epatch "${FILESDIR}/${PV}/fix_zfs-fuse_path.patch"
+ epatch "${FILESDIR}/${PV}/fix_ztest_path.patch"
+}
+
+src_compile() {
+ scons || die "Make failed"
+}
+
+src_install() {
+ if useq debug; then
+ mv cmd/ztest/ztest cmd/ztest/run-ztest || die
+ mv cmd/ztest/runtest.sh cmd/ztest/ztest || die
+ dosbin cmd/ztest/run-ztest || die
+ fi
+ dosbin cmd/ztest/ztest || die
+
+ if useq debug; then
+ mv zfs-fuse/zfs-fuse zfs-fuse/run-zfs-fuse || die
+ mv zfs-fuse/run.sh zfs-fuse/zfs-fuse || die
+ dobin zfs-fuse/run-zfs-fuse || die
+ fi
+ dosbin "zfs-fuse/zfs-fuse" || die
+
+ dosbin "cmd/zfs/zfs" || die
+ dosbin "cmd/zpool/zpool" || die
+ dosbin "cmd/zdb/zdb" || die
+
+ newinitd "${FILESDIR}/${PV}/${PN}.rc" "zfs-fuse" || die
+
+ keepdir /var/lock/zfs || die
+ fowners daemon.disk /var/lock/zfs || die
+
+ keepdir /var/run/zfs || die
+ fowners daemon.disk /var/run/zfs || die
+
+ cd "${WORKDIR}/trunk" || die
+
+ dodoc CHANGES || die
+
+ if use doc; then
+ dodoc {INSTALL,TODO,STATUS,TESTING,HACKING,BUGS} || die
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "To debug and play with ZFS-FUSE make sure you have a recent 2.6.xx"
+ einfo "series kernel with the FUSE module compiled in OR built as a"
+ einfo "kernel module."
+ einfo
+ einfo "You can start the ZFS-FUSE daemon by running"
+ einfo
+ einfo " /etc/init.d/zfs-fuse start"
+ einfo
+ einfo "as root from the command line. "
+ einfo
+ einfo "And don't forget to add it permanently, if you want to:"
+ einfo
+ einfo " rc-update add zfs-fuse boot"
+ einfo
+ einfo "For additional ZFS related commands I recommend the ZFS admin"
+ einfo "guide. http://opensolaris.org/os/community/zfs/docs/zfsadmin.pdf"
+ einfo
+ einfo "Don't forget this is an beta-quality release. Testing has been"
+ einfo "very limited so please make sure you backup any important data."
+ einfo
+ einfo "If you have any problems with zfs-fuse please visit the ZFS-FUSE."
+ einfo "website at http://developer.berlios.de/projects/zfs-fuse/"
+ echo
+}