summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/md5deep/ChangeLog10
-rw-r--r--app-crypt/md5deep/files/md5deep-3.2-as-needed.patch27
-rw-r--r--app-crypt/md5deep/md5deep-3.2.ebuild26
3 files changed, 61 insertions, 2 deletions
diff --git a/app-crypt/md5deep/ChangeLog b/app-crypt/md5deep/ChangeLog
index 7d4e08ede249..3233b2b81177 100644
--- a/app-crypt/md5deep/ChangeLog
+++ b/app-crypt/md5deep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/md5deep
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/ChangeLog,v 1.43 2008/12/10 11:39:39 nyhm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/ChangeLog,v 1.44 2009/01/25 14:13:09 nyhm Exp $
+
+*md5deep-3.2 (25 Jan 2009)
+
+ 25 Jan 2009; Tristan Heaven <nyhm@gentoo.org>
+ +files/md5deep-3.2-as-needed.patch, +md5deep-3.2.ebuild:
+ Version bump
10 Dec 2008; Tristan Heaven <nyhm@gentoo.org>
files/md5deep-3.1-as-needed.patch:
diff --git a/app-crypt/md5deep/files/md5deep-3.2-as-needed.patch b/app-crypt/md5deep/files/md5deep-3.2-as-needed.patch
new file mode 100644
index 000000000000..dc1f87de5f9a
--- /dev/null
+++ b/app-crypt/md5deep/files/md5deep-3.2-as-needed.patch
@@ -0,0 +1,27 @@
+--- hashdeep/Makefile.am
++++ hashdeep/Makefile.am
+@@ -1,5 +1,3 @@
+-# The math library is required for floor()
+-AM_LDFLAGS = -lm
+ INCLUDES = -I@top_srcdir@/include
+ COMMON_DIR = @top_srcdir@/common
+
+@@ -26,7 +24,8 @@
+ # don't have it yet (e.g. OpenSolaris). We if don't have strsep
+ # we compile it ourselves using a local copy.
+ EXTRA_hashdeep_SOURCES = lib-strsep.c
+-hashdeep_LDADD = ${EXTRA_HASHDEEP}
++# The math library is required for floor()
++hashdeep_LDADD = ${EXTRA_HASHDEEP} -lm
+ hashdeep_DEPENDENCIES = ${EXTRA_HASHDEEP}
+
+ EXTRA_DIST = main.h strsep.h ${man_MANS}
+--- md5deep/Makefile.am
++++ md5deep/Makefile.am
+@@ -1,5 +1,5 @@
+
+-AM_LDFLAGS = -lm
++LDADD = -lm
+ INCLUDES = -I@top_srcdir@/include
+ COMMON_DIR = @top_srcdir@/common
+
diff --git a/app-crypt/md5deep/md5deep-3.2.ebuild b/app-crypt/md5deep/md5deep-3.2.ebuild
new file mode 100644
index 000000000000..e3417282d228
--- /dev/null
+++ b/app-crypt/md5deep/md5deep-3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-3.2.ebuild,v 1.1 2009/01/25 14:13:09 nyhm Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Expanded md5sum program with recursive and comparison options"
+HOMEPAGE="http://md5deep.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}