summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-base/xfconf/ChangeLog5
-rw-r--r--xfce-base/xfconf/xfconf-4.6.0.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index a2b651db1dfa..06d485e427f1 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.1 2009/03/10 13:52:05 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.2 2009/03/12 16:19:29 angelos Exp $
+
+ 12 Mar 2009; Christoph Mende <angelos@gentoo.org> xfconf-4.6.0.ebuild:
+ Added USE=perl to install perl bindings
*xfconf-4.6.0 (10 Mar 2009)
diff --git a/xfce-base/xfconf/xfconf-4.6.0.ebuild b/xfce-base/xfconf/xfconf-4.6.0.ebuild
index 57772ac86589..6c71c2cf4052 100644
--- a/xfce-base/xfconf/xfconf-4.6.0.ebuild
+++ b/xfce-base/xfconf/xfconf-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.0.ebuild,v 1.1 2009/03/10 13:52:05 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.0.ebuild,v 1.2 2009/03/12 16:19:29 angelos Exp $
EAPI=1
@@ -10,16 +10,24 @@ xfce4_core
DESCRIPTION="Xfce configuration daemon and utilities"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc"
+IUSE="debug doc -perl"
RDEPEND=">=dev-libs/dbus-glib-0.72
>=dev-libs/glib-2.12:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}"
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ perl? ( dev-perl/glib-perl )"
DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )"
+ doc? ( dev-util/gtk-doc )
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable doc gtk-doc)"
+ XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable perl perl-bindings)"
+}
+
+src_compile() {
+ xfce4_src_configure
+ emake OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
}
DOCS="AUTHORS ChangeLog NEWS README TODO"