summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/libkdepim/ChangeLog11
-rw-r--r--kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch69
-rw-r--r--kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild42
3 files changed, 120 insertions, 2 deletions
diff --git a/kde-base/libkdepim/ChangeLog b/kde-base/libkdepim/ChangeLog
index c90aa8fa05fa..030a4f25f1e3 100644
--- a/kde-base/libkdepim/ChangeLog
+++ b/kde-base/libkdepim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/libkdepim
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkdepim/ChangeLog,v 1.191 2011/06/02 22:05:12 dilfridge Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkdepim/ChangeLog,v 1.192 2012/08/01 22:38:00 dilfridge Exp $
+
+*libkdepim-4.4.11.1-r1 (01 Aug 2012)
+
+ 01 Aug 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch,
+ +libkdepim-4.4.11.1-r1.ebuild:
+ Add upstream bugfixes
02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-libkdepim-4.4.9.ebuild, -libkdepim-4.4.10.ebuild:
diff --git a/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch b/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch
new file mode 100644
index 000000000000..19d8c01666f6
--- /dev/null
+++ b/kde-base/libkdepim/files/4.4/0004-libkdepim-Make-spell-checking-work-again.patch
@@ -0,0 +1,69 @@
+From 6f62ea1bff318d8efea42f59bdc965ee2ab187a0 Mon Sep 17 00:00:00 2001
+From: Thomas McGuire <mcguire@kde.org>
+Date: Wed, 11 May 2011 18:21:32 +0100
+Subject: [PATCH 4/6] Make spell checking work again. The text edit used the
+ wrong config file for loading spell settings. After
+ using the config file, the correct settigns get loaded
+ again, since the Loader from Sonnet is a singleton and
+ therefore shares the settings, so even the textedit
+ with the wrong settings file name gets updated.
+
+cherry-picked from d1708effbb68d6eae36ee5177a599c965973725f.
+
+BUG: 247486
+---
+ kmail/kmcomposereditor.cpp | 2 +-
+ libkdepim/kmeditor.cpp | 12 ++++++++++++
+ libkdepim/kmeditor.h | 6 ++++++
+ 3 files changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/libkdepim/kmeditor.cpp b/libkdepim/kmeditor.cpp
+index e8f0d36..067c781 100644
+--- a/libkdepim/kmeditor.cpp
++++ b/libkdepim/kmeditor.cpp
+@@ -28,6 +28,7 @@
+ #include <KProcess>
+ #include <KPushButton>
+ #include <KTemporaryFile>
++#include <kdeversion.h>
+
+ #include <QApplication>
+ #include <QClipboard>
+@@ -215,6 +216,17 @@ KMeditor::KMeditor( QWidget *parent )
+ d->init();
+ }
+
++KMeditor::KMeditor( QWidget *parent, const QString & configFile )
++#if KDE_IS_VERSION(4,6,0)
++ : TextEdit( parent, configFile ), d( new KMeditorPrivate( this ) )
++#else
++ : TextEdit( parent ), d( new KMeditorPrivate( this ) )
++#endif
++{
++ Q_UNUSED( configFile )
++ d->init();
++}
++
+ KMeditor::~KMeditor()
+ {
+ delete d;
+diff --git a/libkdepim/kmeditor.h b/libkdepim/kmeditor.h
+index 4aab8aa..66ebb4a 100644
+--- a/libkdepim/kmeditor.h
++++ b/libkdepim/kmeditor.h
+@@ -61,6 +61,12 @@ class KDEPIM_EXPORT KMeditor : public KPIMTextEdit::TextEdit
+ */
+ explicit KMeditor( QWidget *parent = 0 );
+
++ /**
++ * Constructs a KMeditor object.
++ */
++ explicit KMeditor( QWidget *parent, const QString& configFile );
++
++
+ virtual ~KMeditor();
+
+ //Redefine it for each apps
+--
+1.7.9.2
+
diff --git a/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild b/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..4def85d305b8
--- /dev/null
+++ b/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkdepim/libkdepim-4.4.11.1-r1.ebuild,v 1.1 2012/08/01 22:38:00 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Common library for KDE PIM apps"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+"
+RDEPEND="${DEPEND}"
+
+# @Since >4.2.65 kode removed from kdepim
+add_blocker kode
+
+KMEXTRACTONLY="
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+"
+
+KMSAVELIBS="true"
+
+# the one test that can be run requires a dbus session bus
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/4.4/"0004-*.patch )
+
+src_install() {
+ kde4-meta_src_install
+
+ # install additional generated headers that are needed by other packages that
+ # are derived from kdepim. e.g. kmail.
+ pushd "${CMAKE_BUILD_DIR}/libkdepim/" 2>/dev/null || die "pushd libkdepim failed"
+ insinto "${PREFIX}/include"
+ doins ui_addresspicker.h ui_categoryselectdialog_base.h || die "Failed to install extra header files."
+ popd 2>/dev/null
+}